POJ - 3259 Wormholes(最短路 Bellman-Ford算法)

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 57342 Accepted: 21388

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Code

#include <cstdio>
#include <cstring>
#include <algorithm>
#define N 10000
#define INF 0x3f3f3f3f

using namespace std;

int dis[N];
int n,m,W,num;

struct node
{
    int s,e,t;
}e[N];

bool Bellman_Ford()
{
    int i,j,flag;   ///flag判断负边权
    for(i=0;i<n;i++)
    {
        dis[i] = INF;
    }
    dis[1] = 0;
    for(i=0;i<n;i++)
    {
        flag = 0;
        for(j=0;j<num;j++)
        {
            if(dis[e[j].e] > dis[e[j].s] + e[j].t)
            {
                dis[e[j].e] = dis[e[j].s] + e[j].t;
                flag = 1;
            }
        }
        if(!flag)   ///没有松弛,一定没有负边
            return false;
    }
    for(i=0;i<num;i++)
    {
        if(dis[e[i].e] > dis[e[i].s] + e[i].t)
            return true;    ///存在负边
    }
    return false;
}

int main()
{
    int T,i,j;
    scanf("%d",&T);
    while(T--)
    {
        num = 0;
        int u,v,w;
        scanf("%d %d %d",&n,&m,&W);
        for(i=0; i<m; i++)
        {
            scanf("%d %d %d",&u,&v,&w);
            e[num].s = u;
            e[num].e = v;
            e[num].t = w;
            num++;
            e[num].s = v;
            e[num].e = u;
            e[num].t = w;
            num++;
        }
        for(i=0;i<W;i++)
        {
            scanf("%d %d %d",&u,&v,&w);
            e[num].s = u;
            e[num].e = v;
            e[num].t = -w;
            num++;
        }
        if(Bellman_Ford())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

反思:

题目大意:约翰农夫发现农场有虫洞,因为他是个狂热的时间旅行爱好者,所以打算皮一下,想试试能不能通过虫洞回到起点看到自己。农场的路径是双向的,虫洞是单向的负边。第一行是数据组数,每组的第一行n,m,w分别是农场数、路径数和虫洞数,接下来m行是连接两边的点和边的权值,再接下来w行是存在虫洞的路径。最短路问题,存在负权边,所以选用Bellman-Ford算法。如果存在负权边,则约翰可以穿越时空看到自己,输出YES,否则就不可以,输出NO。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值