HDU 1029 Ignatius and the Princess IV (简单DP)

hdu 1029

题目:

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 42940    Accepted Submission(s): 18774


 

Problem Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?

 

 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

 

 

Output

For each test case, you have to output only one line which contains the special number you have found.

 

 

Sample Input

 

5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1

 

 

Sample Output

 

3 5 1

题意:一个奇数长的序列中有一个数字出现了至少( n + 1 ) / 2次, 输出这个数。

这题目乍一看觉得异常简单, 不就是找数么, 出现了那么多次还不好找么, 然后想了想就会“真香~”

题解:其实只要明白一件事, 这个题目就非常简单了, 我们把要找的那个数字称作“多数”, 在这个数列中我们任意去掉两个不相同的数字, 之后的数列里, 多数还是多数。所以我们只要遍历一遍数列, 记录下当前的数字以及出现的次数, 每遇到不同的书就将出现次数减一, 出现次数为零时更新数字。

AC代码:

#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
    int i, j, n, q, t, cnt = 0;
    while(~scanf("%d", &n)){
        cnt = 0;//计数器
        for(i = 0;i < n;i++){
            scanf("%d", &q);
            if(!cnt){//cnt为零t肯定不是“多数”
                cnt = 1;
                t = q;//更新数字
            }
            else{
                if(t == q)cnt += 1;//出现次数++
                else cnt -= 1;//去掉一个t 和 一个q
            }
        }
        printf("%d\n", t);//最后剩下的肯定是多数
    }
    return 0;
}

帮忙点一下赞吧~~谢谢。

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值