hdu4278 Faulty Odometer 八进制转十进制

Faulty Odometer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1875    Accepted Submission(s): 1295


Problem Description
  You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 2 to the digit 4 and from the digit 7 to the digit 9, always skipping over the digit 3 and 8. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15229 and the car travels one mile, odometer reading changes to 15240 (instead of 15230).
 

Input
  Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 3 and 8.
 

Output
  Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car. 
 

Sample Input
  
  
15 2005 250 1500 999999 0
 

Sample Output
  
  
15: 12 2005: 1028 250: 160 1500: 768 999999: 262143


#include <cstdio>
#include <cstring>
#include <iostream>

using namespace std;

int ans[50], cnt;

void cc(int n) {
	cnt = 0;
	do {
		ans[cnt++] = n % 10;
		n /= 10;
	} while (n);
	for (int i = 0; i < cnt; i++) {
		if (ans[i] > 3 && ans[i] < 8) {
			ans[i] -= 1;
		}
		else if (ans[i] == 9) {
			ans[i] -= 2;
		}
	}
}

int main()
{
	int n;
	while (~scanf("%d", &n) && n) {
		cc(n);
		int sum = 0;
		for (int i = cnt - 1; i >= 0; i--) {
			sum *= 8;
			sum += ans[i];
		}
		printf("%d: %d\n", n, sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值