杭电1002_A + B Problem II


 
 
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
   
   
2 1 2 112233445566778899 998877665544332211
 

Sample Output
   
   
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
#include <string.h>
#include <stdio.h>
int main(){
    char a[1000],b[1000],c[1000],d[1000];
    int n,i,j,num,a1,b1,y = 0,num1,k=1;
    scanf("%d",&n);
    while(n){
        scanf("%s %s",a,b);
        printf("Case %d:\n",k);
        printf("%s + %s = ",a,b);
        a1 = strlen(a)-1;
        b1 = strlen(b)-1;
        j = 0;
        for(i = a1;i >=0;i--){
            c[j] = a[i];
            j++;
        }
        c[j] = '\0';
        strcpy(a,c);
        j = 0;
        for(i = b1;i >=0;i--){
            c[j] = b[i];
            j++;
        }
        c[j] = '\0';
        strcpy(b,c);// 将两个数组的字符串倒转//
        //将两个字符串相加//
        
        //先判断长度//
         if(a1 == b1){
             for(i = 0;i<a1+1;i++){
                 if( (a[i]+b[i]) - 48*2 +y >=10)    {c[i] = (a[i]+b[i] - 48*2 +y)%10+48;y = 1;}
                 else    {c[i] = (a[i]+b[i]) - 48 +y;y = 0;}
             }
             if(y == 1)    {c[i] = '1';c[i+1] = '\0';}
             else if(y == 0)        {c[i] = '\0';}
         }
         //现在为两个长度不相等的//
         else{
             if(a1 < b1)    {
                num = b1 - a1;
                for(i = a1+1;i < b1+1;i++)
                    a[i] = '0';
                    a[i] = '\0';
            for(i = 0;i<b1+1;i++){
                if(a[i]+b[i]-48*2+y>=10)    {c[i] = (a[i]+b[i]-48*2+y)%10+48;y=1;}
                else    {c[i] = a[i]+b[i] - 48 +y;y = 0;}
            } 
            if(y == 1)    {c[i] = '1';c[i+1] = '\0';}
            else if(y == 0) {c[i] = '\0';}
            }
            else if(a1 > b1){
                num = a1 - b1;
                for(i = b1+1;i<a1+1;i++)
                    b[i] = '0';
                    b[i] = '\0';
            
            //以上为其数组补0//
            for(i = 0;i<a1+1;i++){
                if(a[i]+b[i]-48*2+y>=10)    {c[i] = (a[i]+b[i]-48*2+y)%10+48;y=1;}
                else    {c[i] = a[i]+b[i] - 48 +y;y = 0;}
            } 
            if(y == 1)    {c[i] = '1';c[i+1] = '\0';}
            else if(y == 0) {c[i] = '\0';}
            } 
         } 
         num1 = strlen(c)-1;
         for(i = num1;i>=0;i--)    printf("%c",c[i]);
         if(n != 1)                printf("\n\n");
         else                    printf("\n");
         n--;
         k++;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值