杭电1028_Ignatius and the Princess III(母函数、DP)——java

Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
 
 
4 10 20
 

Sample Output
 
 
5 42 627


母函数:

import java.util.Scanner;

public class Main{

    public static void main(String[] args){

        Scanner sc = new Scanner(System.in);

        while(sc.hasNextInt()){
            int n = sc.nextInt();
            int[] s1 =  new int[300];
            int[] s2 =  new int[300];

            for(int i = 0; i <= n;i++){
                s1[i] = 1;//初始化第一个括号中的系数,s1[i]这里代表指数为i的项的系数。
                s2[i] = 0;
            }

            for(int i = 2;i <= n;i++){
                for(int j = 0; j <= n ;j++){
                    for(int k = 0; k + j <=n;k+=i){
                        s2[j+k] +=s1[j];
                    }
                }
                for(int j = 0;j<=n ;j++){
                    s1[j] = s2[j];
                    s2[j] = 0;
                }
            }
            System.out.println(s1[n]);
        }
    }
}


DP:

import java.util.Scanner;

public class Main{

    public static void main(String[] args){
        Scanner sc  = new Scanner(System.in);
        int[][] a = new int[130][130];
        fn(120,120,a);
        while(sc.hasNextInt()){
            int n = sc.nextInt();

            System.out.println(fn(n,n,a));
        }
    }
    public static int fn(int n ,int m,int[][] a){
        if(a[n][m] != 0)
            return a[n][m];
        if(n < 1 || m < 1)
            return a[n][m] = 0;
        if(n == 1||m==0){
            return 1;
        }
        if( n < m){
            return a[n][m] = fn(n,n,a);
        }
        if(n == m){
            return a[n][m] = (fn(n,m-1,a) + 1);
        }
        else
            return a[n][m] = (fn(n,m-1,a) + fn(n-m,m,a));
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值