hdu 3018 Ant Trip (欧拉回路)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3018

Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country.

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.

 

 

Input

Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.

 

 

Output

For each test case ,output the least groups that needs to form to achieve their goal.

 

 

Sample Input

 

3 3 1 2 2 3 1 3 4 2 1 2 3 4

 

 

Sample Output

 

1 2

 

非(半)欧拉图需要的笔数==该图中奇数度的点数目/2

#pragma GCC optimize(2)
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<set>
#include<vector>
#include<queue>
using namespace std;
const int maxn = 1e5 + 100;
const int inf = 0x3f3f3f3f;
typedef long long ll;
int f[maxn];
int n, m;
int in[maxn], ou[maxn], deg[maxn];
void init(int n)
{
	for (int i = 0; i <= n; i++)
	{
		f[i] = i;
	}
	memset(in, 0, sizeof(in));
	memset(ou, 0, sizeof(ou));
	memset(deg, 0, sizeof(deg));
	return;
}
int find(int x)
{
	if (x == f[x])
	{
		return x;
	}
	else
	{
		f[x] = find(f[x]);
	}
}
int main()
{
	//freopen("C://input.txt", "r", stdin);
	while (scanf("%d%d", &n,&m) !=EOF)
	{
		init(n);
		for (int i = 1; i <= m; i++)
		{
			int u, v;
			scanf("%d%d", &u, &v);
			deg[u]++;
			deg[v]++;
			u = find(u);
			v = find(v);
			if (u != v)
			{
				f[v] = u;
			}
		}
		for (int i = 1; i <= n; i++)
		{
			in[find(i)]++;
			if (deg[i] % 2 == 1)
			{
				ou[find(i)]++;
			}
		}
		int ans = 0;
		for (int i = 1; i <= n; i++)
		{
			if (in[i] <= 1)
			{
				continue;
			}
			else if (ou[i] == 0)
			{
				ans++;
			}
			else if (ou[i] > 0)
			{
				ans += ou[i] / 2;
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值