HDU 3018 Ant Trip 笔记

Ant Trip

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3686 Accepted Submission(s): 1460

Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country.

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.

Output
For each test case ,output the least groups that needs to form to achieve their goal.

Sample Input
3 3
1 2
2 3
1 3

4 2
1 2
3 4

Sample Output
1
2

Hint

New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town.
In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3.
In sample 2,tony and his friends must form two group.

Source
2009 Multi-University Training Contest 12 - Host by FZU

Recommend
gaojie | We have carefully selected several similar problems for you: 3013 3015 3016 3011 3010


简答解释下题意,就是N个点,M条边,求几笔画才能走完。要注意的是,这里是排除了单独点的情况,就是说,入度=出度=0的点是不考虑的。

这个题就是,找出所有连通图,走完一个连通图的笔画数是奇度顶点数/2,如果奇度顶点,必然是欧拉回路,可以一笔画走完。

欧拉环(回路)的充要条件是所有顶点的度为偶数

所以整个题的思路是,用并查集建立连通图,然后统计连通图中奇度顶点的个数,最后累加就是结果了。我在统计连通图奇度顶点个数的时候犯了个愚蠢的错误,导致WA了好几次:就是每个连通图的奇度顶点个数是记录在并查集根结点上的,而遍历的时候遍历的是每个顶点(树的结点),应该判断顶点的度,来修改根节点对应的奇度顶点个数。看起来很简单,但是写到代码里的时候还是要注意一些细节

#include <cstdio>
#include <cstring>
using namespace std;
const int MAX = 100000+10;

int pre[MAX];
int degree[MAX];
int flag[MAX];
inline void init(int n);
void init(int n){
    for (int i = 1; i <= n; ++i)
        pre[i] = i;
    memset(degree, 0, sizeof(int)*MAX);
    memset(flag, -1, sizeof(int)*MAX);
}
int find(int x){
    if (x != pre[x])
        pre[x] = find(pre[x]);
    return pre[x];
}
inline void combine(int x, int y);
void combine(int x, int y){
    int t_x = find(x);
    int t_y = find(y);

    if (t_x != t_y)
        pre[t_y] = pre[t_x];
}
int main(){
    int n, m;
    while (~scanf("%d %d", &n,&m)){
        init(n);
        int a, b;
        for (int i = 0; i < m; ++i){
            scanf("%d %d", &a, &b);
            ++degree[a];
            ++degree[b];
            combine(a, b);
        }
        int p;
        for (int i = 1; i <= n; ++i){
            p = find(i);
            if (flag[p] == -1 && degree[i] > 0) //第一次出现,不论奇偶度顶点
                flag[p] = 0;
            if (degree[i] % 2 != 0)        //奇度顶点
                ++flag[p];
        }
        int ans = 0;
        for (int i = 1; i <= n; ++i){
            if (flag[i] == 0) ++ans;
            else if (flag[i] > 0) ans += flag[i] / 2;
        }
        printf("%d\n", ans);
    }

    return 0;
}

参考资料:http://blog.csdn.net/ZYY173533832/article/details/10308311

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值