Fibonacci Again(HDU1021)

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25104    Accepted Submission(s): 12153


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
   
   
0 1 2 3 4 5
 

Sample Output
   
   
no no yes no no no
 


解题思路:
先编写一个代码找规律,输出F[i] % 3 == 0 ( 0 <= i < 100);

#include <iostream>
using namespace std;

int main()
{
 int i , n , F[101];
 F[0] = 7;
 F[1] = 11;
 for(i = 2 ; i < 100; i++)
 {
  F[i] = F[i-1] + F[i-2];
  if(F[i] % 3 == 0)
   printf("%d " ,i);
 }
 return 0;
}
结果输出:
2 6 10 14 18 22 26 30 34 38 42 46 50 54 58 62 66 70 74 78 82 86 90 94 98
规律:每一个数减二都可以整除四;
最终代码:
#include <iostream>
using namespace std;

int main()
{
 int  n ;
 while(scanf("%d" , &n) != EOF)
 {
  if((n-2) % 4 == 0)
   printf("yes\n");
  else
   printf("no\n");
 }
 return 0;
}


总结:大多数简单的数学问题都是有规律可寻 ,要加强统计能力;
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值