HDU1021——Fibonacci Again

4 篇文章 0 订阅

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52808    Accepted Submission(s): 24967



Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no
 
解:简直就是个坑啊,,,,,一开始看到1000000级别想到打表遍历一次就好,但是1000000的Fibonacci 正常的64位整数放不开,所以不能求出数值,只有找规律了,每八个数一段,每一段的第3个和第7个满足条件,因从0开始,则(n%8==2 || n%8==6)即可。

#include<stdio.h>

long long a[1000005]; 

int main()
{
	 
	long long n;
	while(~scanf("%I64d",&n)){
		if(n%8==2 || n%8==6){
			printf("yes\n");
		}else{
			printf("no\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值