hdu1021——Fibonacci Again

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47893    Accepted Submission(s): 22743


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no

感觉自己学聪明了,第一眼看到这题后想到的不是暴力算,而是找规律。

判断能不能被3整除,那么整个斐波那契数列只需要保留0,1,2,这三个数就行了。只有三个数,那么很有可能在某处存在一个周期。结果推出了前10个,分别是1,2,0,2,2,1,0,1,1,2。这是周期已经出现了,为8。

代码实现如下:

#include<iostream>
using namespace std;
int main()
{
	int n;
	while(cin>>n)
	{
		if(n%8==2||n%8==6) cout<<"yes"<<endl;
		else cout<<"no"<<endl;
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值