A+B Coming

Problem Description
Many classmates said to me that A+B is must needs.
If you can’t AC this problem, you would invite me for night meal. ^_^
 

Input
Input may contain multiple test cases. Each case contains A and B in one line.
A, B are hexadecimal number.
Input terminates by EOF.
 

Output
Output A+B in decimal number in one line.
 

Sample Input
 
 
1 9 A B a b
 

Sample Output
 
 
10 21 21
 

Author
威士忌


当年做的第一道英文题,解题的重点就在于hexadecimal和decimal。表明输入的为十六进制,却要输出十进制的和。这样题目就十分简单了,但是当时自己用的是C语言,使用printf输出,但是需要把a,b换为大写,无意中增加了不少麻烦,而且还用到了字符数组。现在学过了C++后,发现聪明的cin与cout轻松地解决了这一切。

P.S:C语言输出十六进制数要用到格式控制符%x

      而C++用个hex就搞定了(Io流输入真是好用)

#include<iostream>
using namespace std;
int main()
{
	int A,B;
	while(cin>>hex>>A>>B)
	{
		cout<<dec<<A+B<<endl;
	}
	return 0;
}
怎么样,是不是很简单啊。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值