1001 A+B Format (20 分)

Calculate a + b a+b a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a a a and b b b where − 1 0 6 ≤ a , b ≤ 1 0 6 -10^6 \le a, b \le 10^6 106a,b106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a a a and b b b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题解

计算 A + B A+B A+B,输出时每隔三位在数字间加上","。

从前到后输出每一位,如果当前位满足(i + 1) % 3 == len % 3(i从0开始),那么就应该在这位之后输出一个逗号,排除负号和最后一位的情况。

#include <iostream>
#include <string>

using namespace std;

int main() {
    int a, b;
    cin >> a >> b;

    string s = to_string(a + b);

    for (int i = 0, len = s.length(); i < len; i++) {
        cout << s[i];
        if (s[i] == '-' or i == len - 1)
            continue;
        if ((i + 1) % 3 == len % 3)
            cout << ",";
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值