PAT (Advanced Level) Practice 1010 Radix(25分)【 二分答案、进制转换】

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N 1 N_1 N1 and N 2 N_2 N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

题意

给出两个数和其中一个数的进制,问是否有可能在另一个数为某个进制时,这两个数相等。

思路

首先把已知进制的那个数转化为十进制,然后对第二个数二分答案,二分答案的左边界是第一个数中最大的数字+1,这个最大的数字可以直接使用algorithm库中的max_element得到。右边界是第一个数的值+1。在二分答案时,进制转换时有可能会出现溢出的情况,说明这个数太大了。

代码

#include <cstring>
#include <cctype>
#include <cstdio>
#include <algorithm>

using namespace std;

typedef long long ll;
char n1[15], n2[15];

int to_num(char a) {
    if (isdigit(a)) return a - '0';
    else return a - 'a' + 10;
}

ll convert(char x[], int rad) {
    ll val = 0;
    for (int i = 0, len = strlen(x); i < len; ++i) {
        val = val * rad + to_num(x[i]);
        if (val <= 0) return -1;  // 溢出返回-1
    }
    return val;
}

ll b_search(char x[], ll t) {
    int len = strlen(x);
    ll left = to_num(*max_element(x, x + len)) + 1, right = t + 1, mid;
    while (left <= right) {
        mid = (left + right) / 2;
        ll val = convert(x, mid);
        if (val < 0 || val > t) right = mid - 1;
        else if (val < t) left = mid + 1;
        else if (val == t) return mid;
    }
    return -1;
}

int main() {
    int tag, rad;
    scanf("%s %s %d %d", n1, n2, &tag, &rad);
    if (tag == 2) swap(n1, n2);

    ll v1 = convert(n1, rad);
    ll n2_rad = b_search(n2, v1);

    if (n2_rad == -1) printf("Impossible");
    else printf("%lld", n2_rad);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值