PAT(甲级)2019年春季考试 7-1 Sexy Primes (20 分)

Sexy primes are pairs of primes of the form ( p p p, p + 6 p+6 p+6), so-named since “sex” is the Latin word for “six”. (Quoted from http://mathworld.wolfram.com/SexyPrimes.html)
Now given an integer, you are supposed to tell if it is a sexy prime.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N N N (≤ 1 0 8 10^8 108).

Output Specification:

For each case, print in a line Yes if N is a sexy prime, then print in the next line the other sexy prime paired with N N N (if the answer is not unique, output the smaller number). Or if N N N is not a sexy prime, print No instead, then print in the next line the smallest sexy prime which is larger than N N N.

Sample Input 1:

47

Sample Output 1:

Yes
41

Sample Input 2:

21

Sample Output 2:

No
23

题意

一个数x是“sexy prime”指的是x是质数且x-6或x+6也是质数。
给出一个数,判断这个数是不是“sexy prime”,如果是的话输出与这个数配对的另一个“sexy prime”,如果有多个就输出小的那个(也就是x-6),如果不是就输出最小的比这个数大的“sexy prime”。

思路

这道题很简单啦,注意一下判断质数的函数前面要先判断x<=1,如果是的话直接返回false

代码

#include <iostream>
#include <cmath>

using namespace std;

bool isPrime(int x) {
    if (x <= 1) return false;
    int sqr = sqrt(x);
    for (int i = 2; i <= sqr; ++i)
        if (x % i == 0) return false;
    return true;
}

int isSexy(int x) {
    if (isPrime(x)) {
        if (isPrime(x - 6)) return x - 6;
        if (isPrime(x + 6)) return x + 6;
    }
    return -1;
}

int main() {
    int a, b;
    cin >> a;

    if ((b = isSexy(a)) != -1) cout << "Yes\n" << b;
    else {
        while (isSexy(++a) == -1);
        cout << "No\n" << a;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值