PAT(甲级)2019年秋季考试 7-1 Forever (20 分)

“Forever number” is a positive integer A A A with K K K digits, satisfying the following constrains:

  • the sum of all the digits of A A A is m m m;
  • the sum of all the digits of A + 1 A+1 A+1 is n n n; and
  • the greatest common divisor of m m m and n n n is a prime number which is greater than 2.

Now you are supposed to find these forever numbers.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N N N ( ≤ 5 ≤5 5). Then N N N lines follow, each gives a pair of K K K ( 3 &lt; K &lt; 10 3&lt;K&lt;10 3<K<10) and m m m ( 1 &lt; m &lt; 90 1&lt;m&lt;90 1<m<90), of which the meanings are given in the problem description.

Output Specification:

For each pair of K K K and m m m, first print in a line Case X, where X is the case index (starts from 1). Then print n n n and A A A in the following line. The numbers must be separated by a space. If the solution is not unique, output in the ascending order of n n n. If still not unique, output in the ascending order of A A A. If there is no solution, output No Solution.

Sample Input:

2
6 45
7 80

Sample Output:

Case 1
10 189999
10 279999
10 369999
10 459999
10 549999
10 639999
10 729999
10 819999
10 909999
Case 2
No Solution

题意

给出K和m。计算所有满足条件的数A,A有K位,A的数字和是m,A+1的数字和n与m的最大公约数是大于2的质数。输出满足条件的n和A,按照升序排列,其中n是第一标尺,A是第二标尺。

思路

暴力的话会超时,可以dfs并且剪枝,剪枝的依据是当前的数字和是否还有可能产生满足条件的A。
话说这道题放到第1题的位置真的好吗……

代码

#include <iostream>
#include <cstdio>
#include <vector>
#include <cmath>
#include <string>
#include <algorithm>

using namespace std;

bool isPrime(int x) {
    if (x <= 1) return false;
    for (int i = 2, sqr = sqrt(x); i <= sqr; ++i) {
        if (x % i == 0) return false;
    }
    return true;
}

int gcd(int a, int b) {
    if (b == 0) return a;
    else return gcd(b, a % b);
}

int digitSum(int x) {
    int sum = 0;

    string s = to_string(x);
    for (int i = 0, len = s.length(); i < len; ++i)
        sum += s[i] - '0';

    return sum;
}

struct record {
    int sum, val;

    record(int v, int n) : val(v), sum(n) {}

    bool operator<(record &x) {
        if (sum != x.sum) return sum < x.sum;
        else return val < x.val;
    }
};

vector<record> r;

void dfs(int sum, int val, int left, int target) {
    if (left == 0 && sum == target) {
        int n = digitSum(val + 1), g = gcd(sum, n);
        if (g > 2 && isPrime(g)) r.push_back(record(val, n));
    } else if (left > 0)
        for (int i = 0; i <= 9; ++i)
            if (sum + i + left * 9 - 9 >= target && sum + i <= target)
                dfs(sum + i, val * 10 + i, left - 1, target);
}

int main() {
//    freopen("in.txt", "r", stdin);
//    freopen("out.txt", "w", stdout);

    int n, k, m;
    cin >> n;
    for (int i = 1; i <= n; ++i) {
        r.clear();
        cin >> k >> m;
        cout << "Case " << i << "\n";
        for (int j = 1; j <= 9; ++j) dfs(j, j, k - 1, m);
        if (r.empty()) cout << "No Solution\n";
        else {
            sort(r.begin(), r.end());
            for (int j = 0; j < r.size(); ++j)
                cout << r[j].sum << " " << r[j].val << "\n";
        }
    }
}
  • 7
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值