PAT(甲级)2019年秋季考试 7-1 Forever (20分)

7-1 Forever (20分)

状态:ACed

“Forever number” is a positive integer A with K digits, satisfying the following constrains:

the sum of all the digits of A is m;
the sum of all the digits of A+1 is n; and
the greatest common divisor of m and n is a prime number which is greater than 2.
Now you are supposed to find these forever numbers.

Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (≤5). Then N lines follow, each gives a pair of K (3<K<10) and m (1<m<90), of which the meanings are given in the problem description.

Output Specification:
For each pair of K and m, first print in a line Case X, where X is the case index (starts from 1). Then print n and A in the following line. The numbers must be separated by a space. If the solution is not unique, output in the ascending order of n. If still not unique, output in the ascending order of A. If there is no solution, output No Solution.

Sample Input:

2
6 45
7 80

Sample Output:

Case 1
10 189999
10 279999
10 369999
10 459999
10 549999
10 639999
10 729999
10 819999
10 909999
Case 2
No Solution

#include <iostream>
#include <stack>
#include <map>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;
typedef pair<int, int> P;
//const int maxn = 100010;
int n, k, m;
vector<P> res;
int cal_D(int x) { //计算各位数之和
    int ans = 0;
    while (x)
    {
        ans += x % 10;
        x /= 10;
    }
    return ans;
}
bool isP(int x) {
    if (x <= 2) return false; //确保比2大
    for (int i = 2; i*i <= x; i++)
        if (x%i == 0) return false;
    return true;
}
int gcd(int a, int b) { //辗转相除法
    return a % b ? gcd(b, a%b) : b;
}
bool judge(int a, int &show) {
    int b = a + 1;
    show = cal_D(b);
    int c = gcd(m, show);
    return isP(c);
}
void dfs(string& s, int index, int dight, int sum) {
    if (sum > m || index >= k) return; //如果sum大于要求或者超过k位,退出
    if (sum + 9 * (k - index - 1) < m) return; //如果剩余的全是9仍达不到要求的和,退出(剪枝)
    s[index] = '0' + dight;
    if (sum == m && index == k - 1) {
        int a = stoi(s), show;
        if (judge(a, show)) {
            res.push_back(make_pair(show, a));
        }
        return;
    }
    for (int i = 0; i < 10; i++)
        dfs(s, index + 1, i, sum + i);
}
int main() {
    //freopen("test.txt", "r", stdin);
    cin >> n;
    for (int case_i = 1; case_i <= n; case_i++)
    {
        res.clear();
        printf("Case %d\n", case_i);
        cin >> k >> m;
        string str(k, '0');
        for (int i = 1; i < 10; i++)
        {
            //这个坑一定要注意,第一位不能是0,从1开始
            dfs(str, 0, i, i);
        }
        if (res.empty()) printf("No Solution\n");
        else {
            sort(res.begin(), res.end(), [](P a, P b) {
                if (a.first == b.first)
                    return a.second < b.second;
                return a.first < b.first;
            });
            for (auto e : res) {
                printf("%d %d\n", e.first, e.second);
            }
        }

    }
    return 0;
}

对于一个20分的题有点不太显然了吧,哭了。

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值