PAT (Advanced Level) Practice 1076 Forwards on Weibo(30分)【图的遍历、BFS】

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L L L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N ( ≤ 1000 ) N (≤1000) N(1000), the number of users; and L ( ≤ 6 ) L (≤6) L(6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N N N. Then N N N lines follow, each in the format:

M[i] user_list[i]

where M[i] ( ≤ 100 ) (≤100) (100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L L L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

题意

给出N个人的关注列表,和最大计算层数L,计算一个人发一条微博最多能被多少人转发。

思路

根据输入建立有向图时,要从被关注者指向关注者,这是传播的方向。在进行BFS时要记录每个节点的层数,当节点层数达到最大值时不再入栈。

代码

#include <algorithm>
#include <iostream>
#include <queue>
#include <vector>

using namespace std;

struct node {
    int level;
    vector<int> follower;
} nodes[1005];

bool visited[1005];

int bfs(int x, int maxLevel, int n) {
    fill_n(visited + 1, n, false);

    int cnt = 0;
    queue<int> q;
    q.push(x);
    visited[x] = true;
    nodes[x].level = 0;

    while (not q.empty()) {
        int f = q.front();
        q.pop();
        if (nodes[f].level < maxLevel) {
            for (auto &e : nodes[f].follower) {
                if (not visited[e]) {
                    ++cnt;
                    nodes[e].level = nodes[f].level + 1;
                    visited[e] = true;
                    q.push(e);
                }
            }
        }
    }

    return cnt;
}

int main() {
    int n, l, m, c, q, k;

    cin >> n >> l;
    for (int i = 1; i <= n; ++i) {
        cin >> m;
        for (int j = 0; j < m; ++j) {
            cin >> c;
            nodes[c].follower.push_back(i);
        }
    }

    cin >> k;
    for (int i = 0; i < k; ++i) {
        cin >> q;
        cout << bfs(q, l, n) << "\n";
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值