PAT (Advanced Level) Practice 1087 All Roads Lead to Rome(30分)【最短路径】

Indeed there are many different tourist routes from our city to Rome. You are supposed to find your clients the route with the least cost while gaining the most happiness.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N ( 2 ≤ N ≤ 200 ) N (2≤N≤200) N(2N200), the number of cities, and K K K, the total number of routes between pairs of cities; followed by the name of the starting city. The next N − 1 N−1 N1 lines each gives the name of a city and an integer that represents the happiness one can gain from that city, except the starting city. Then K K K lines follow, each describes a route between two cities in the format City1 City2 Cost. Here the name of a city is a string of 3 capital English letters, and the destination is always ROM which represents Rome.

Output Specification:

For each test case, we are supposed to find the route with the least cost. If such a route is not unique, the one with the maximum happiness will be recommanded. If such a route is still not unique, then we output the one with the maximum average happiness – it is guaranteed by the judge that such a solution exists and is unique.

Hence in the first line of output, you must print 4 numbers: the number of different routes with the least cost, the cost, the happiness, and the average happiness (take the integer part only) of the recommanded route. Then in the next line, you are supposed to print the route in the format City1->City2->...->ROM.

Sample Input:

6 7 HZH
ROM 100
PKN 40
GDN 55
PRS 95
BLN 80
ROM GDN 1
BLN ROM 1
HZH PKN 1
PRS ROM 2
BLN HZH 2
PKN GDN 1
HZH PRS 1

Sample Output:

3 3 195 97
HZH->PRS->ROM

题意

给出一个图,带有点权和边权,求最短路径。第一标尺是边权之和尽量小,第二标尺是点权之和尽量大,第三标尺是平均点权尽量大。源点点权不计算。

思路

第一标尺只需运行一次最短路径算法。
第三标尺破坏了最短路径问题的最优子结构(因为这个值有可能会随着路径的增长而变小),所以只能在求最短路径时构建最短路径树,然后使用深搜来枚举所有最短路径。
第二标尺虽然也可以在计算最短路径时考虑,但是基于这道题的特点,也放在深搜中了。

代码

#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <map>
#include <unordered_map>
#include <string>

using namespace std;

struct node {
    string v;
    int weight;

    bool operator>(const node& e) const {
        return weight > e.weight;
    }
};

map<string, vector<string>> pre;  // 最短路径中的前驱
map<string, vector<node>> graph;  // 图
unordered_map<string, bool> vis;  // 访问标志
unordered_map<string, int> dist, happiness, pathCnt;  // 最短路径估计 快乐值 最短路径个数

void dijkstra(string start) {
    dist[start] = 0;
    pathCnt[start] = 1;

    priority_queue<node, vector<node>, greater<node>> pq;
    pq.push({ start, 0 });

    while (not pq.empty()) {
        node top = pq.top();
        pq.pop();

        string u = top.v;
        int uDist = top.weight;

        vis[u] = true;

        if (dist.count(u) && dist[u] < uDist)
          continue;
        for (auto& e : graph[u]) {
            string v = e.v;
            int uvWeight = e.weight;

            if (not vis[v] and (dist.count(v) == 0 or dist[v] > dist[u] + uvWeight)) {
                dist[v] = dist[u] + uvWeight;
                pq.push({ v, dist[v] });

                pre[v].clear();
                pre[v].push_back(u);

                pathCnt[v] = pathCnt[u];
            }
            else if (dist[v] == dist[u] + uvWeight) {
                pre[v].push_back(u);
                pathCnt[v] += pathCnt[u];
            }
        }
    }
}

int maxSumHappiness = 0;
double maxAvgHappiness = 0;
vector<string> tempPath, path;

void dfs(string name, int sumHappiness) {
    tempPath.push_back(name);
    if (pre[name].empty()) {  // 深搜到了路径的源点
      double avgHappiness  = double(sumHappiness) / (int(tempPath.size()) - 1);
      if (sumHappiness > maxSumHappiness 
          or (sumHappiness == maxSumHappiness and avgHappiness > maxAvgHappiness)) {
        maxSumHappiness = sumHappiness;
        maxAvgHappiness = avgHappiness;

        path = tempPath;
        reverse(path.begin(), path.end());
      }
    } else {
        for (auto e : pre[name])
            dfs(e, sumHappiness + happiness[e]);
    }
    tempPath.pop_back();
}

int main() {
    int n, k;
    string start, end = "ROM";
    cin >> n >> k >> start;

    // 读取每个城市的快乐值
    for (int i = 0; i < n - 1; ++i) {
        int happy;
        string name;
        cin >> name >> happy;
        happiness[name] = happy;
    }

    // 读取所有的道路
    for (int i = 0; i < k; ++i) {
        int cost;
        string c1, c2;
        
        cin >> c1 >> c2 >> cost;

        graph[c1].push_back({ c2, cost });
        graph[c2].push_back({ c1, cost });
    }

    dijkstra(start);  // dijkstra找出所有最短路径
    dfs(end, happiness[end]);       // dfs选出快乐值最大且平均快乐值尽可能大的最短路径

    cout << pathCnt["ROM"] << " " << dist["ROM"] << " "
         << maxSumHappiness << " " << int(maxAvgHappiness) << "\n";

    for (auto iter = path.begin(); iter != path.end(); ++iter) {
        cout << *iter;
        if (iter + 1 != path.end()) cout << "->";
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
C语言是一种广泛使用的编程语言,它具有高效、灵活、可移植性强等特点,被广泛应用于操作系统、嵌入式系统、数据库、编译器等领域的开发。C语言的基本语法包括变量、数据类型、运算符、控制结构(如if语句、循环语句等)、函数、指针等。下面详细介绍C语言的基本概念和语法。 1. 变量和数据类型 在C语言中,变量用于存储数据,数据类型用于定义变量的类型和范围。C语言支持多种数据类型,包括基本数据类型(如int、float、char等)和复合数据类型(如结构体、联合等)。 2. 运算符 C语言中常用的运算符包括算术运算符(如+、、、/等)、关系运算符(如==、!=、、=、<、<=等)、逻辑运算符(如&&、||、!等)。此外,还有位运算符(如&、|、^等)和指针运算符(如、等)。 3. 控制结构 C语言中常用的控制结构包括if语句、循环语句(如for、while等)和switch语句。通过这些控制结构,可以实现程序的分支、循环和多路选择等功能。 4. 函数 函数是C语言中用于封装代码的单元,可以实现代码的复用和模块化。C语言中定义函数使用关键字“void”或返回值类型(如int、float等),并通过“{”和“}”括起来的代码块来实现函数的功能。 5. 指针 指针是C语言中用于存储变量地址的变量。通过指针,可以实现对内存的间接访问和修改。C语言中定义指针使用星号()符号,指向数组、字符串和结构体等数据结构时,还需要注意数组名和字符串常量的特殊性质。 6. 数组和字符串 数组是C语言中用于存储同类型数据的结构,可以通过索引访问和修改数组中的元素。字符串是C语言中用于存储文本数据的特殊类型,通常以字符串常量的形式出现,用双引号("...")括起来,末尾自动添加'\0'字符。 7. 结构体和联合 结构体和联合是C语言中用于存储不同类型数据的复合数据类型。结构体由多个成员组成,每个成员可以是不同的数据类型;联合由多个变量组成,它们共用同一块内存空间。通过结构体和联合,可以实现数据的封装和抽象。 8. 文件操作 C语言中通过文件操作函数(如fopen、fclose、fread、fwrite等)实现对文件的读写操作。文件操作函数通常返回文件指针,用于表示打开的文件。通过文件指针,可以进行文件的定位、读写等操作。 总之,C语言是一种功能强大、灵活高效的编程语言,广泛应用于各种领域。掌握C语言的基本语法和数据结构,可以为编程学习和实践打下坚实的基础。
该资源内项目源码是个人的课程设计、毕业设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。 该资源内项目源码是个人的课程设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值