PAT (Advanced Level) Practice 1087 All Roads Lead to Rome(30分)【最短路径】

Indeed there are many different tourist routes from our city to Rome. You are supposed to find your clients the route with the least cost while gaining the most happiness.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N ( 2 ≤ N ≤ 200 ) N (2≤N≤200) N(2N200), the number of cities, and K K K, the total number of routes between pairs of cities; followed by the name of the starting city. The next N − 1 N−1 N1 lines each gives the name of a city and an integer that represents the happiness one can gain from that city, except the starting city. Then K K K lines follow, each describes a route between two cities in the format City1 City2 Cost. Here the name of a city is a string of 3 capital English letters, and the destination is always ROM which represents Rome.

Output Specification:

For each test case, we are supposed to find the route with the least cost. If such a route is not unique, the one with the maximum happiness will be recommanded. If such a route is still not unique, then we output the one with the maximum average happiness – it is guaranteed by the judge that such a solution exists and is unique.

Hence in the first line of output, you must print 4 numbers: the number of different routes with the least cost, the cost, the happiness, and the average happiness (take the integer part only) of the recommanded route. Then in the next line, you are supposed to print the route in the format City1->City2->...->ROM.

Sample Input:

6 7 HZH
ROM 100
PKN 40
GDN 55
PRS 95
BLN 80
ROM GDN 1
BLN ROM 1
HZH PKN 1
PRS ROM 2
BLN HZH 2
PKN GDN 1
HZH PRS 1

Sample Output:

3 3 195 97
HZH->PRS->ROM

题意

给出一个图,带有点权和边权,求最短路径。第一标尺是边权之和尽量小,第二标尺是点权之和尽量大,第三标尺是平均点权尽量大。源点点权不计算。

思路

第一标尺只需运行一次最短路径算法。
第三标尺破坏了最短路径问题的最优子结构(因为这个值有可能会随着路径的增长而变小),所以只能在求最短路径时构建最短路径树,然后使用深搜来枚举所有最短路径。
第二标尺虽然也可以在计算最短路径时考虑,但是基于这道题的特点,也放在深搜中了。

代码

#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <map>
#include <unordered_map>
#include <string>

using namespace std;

struct node {
    string v;
    int weight;

    bool operator>(const node& e) const {
        return weight > e.weight;
    }
};

map<string, vector<string>> pre;  // 最短路径中的前驱
map<string, vector<node>> graph;  // 图
unordered_map<string, bool> vis;  // 访问标志
unordered_map<string, int> dist, happiness, pathCnt;  // 最短路径估计 快乐值 最短路径个数

void dijkstra(string start) {
    dist[start] = 0;
    pathCnt[start] = 1;

    priority_queue<node, vector<node>, greater<node>> pq;
    pq.push({ start, 0 });

    while (not pq.empty()) {
        node top = pq.top();
        pq.pop();

        string u = top.v;
        int uDist = top.weight;

        vis[u] = true;

        if (dist.count(u) && dist[u] < uDist)
          continue;
        for (auto& e : graph[u]) {
            string v = e.v;
            int uvWeight = e.weight;

            if (not vis[v] and (dist.count(v) == 0 or dist[v] > dist[u] + uvWeight)) {
                dist[v] = dist[u] + uvWeight;
                pq.push({ v, dist[v] });

                pre[v].clear();
                pre[v].push_back(u);

                pathCnt[v] = pathCnt[u];
            }
            else if (dist[v] == dist[u] + uvWeight) {
                pre[v].push_back(u);
                pathCnt[v] += pathCnt[u];
            }
        }
    }
}

int maxSumHappiness = 0;
double maxAvgHappiness = 0;
vector<string> tempPath, path;

void dfs(string name, int sumHappiness) {
    tempPath.push_back(name);
    if (pre[name].empty()) {  // 深搜到了路径的源点
      double avgHappiness  = double(sumHappiness) / (int(tempPath.size()) - 1);
      if (sumHappiness > maxSumHappiness 
          or (sumHappiness == maxSumHappiness and avgHappiness > maxAvgHappiness)) {
        maxSumHappiness = sumHappiness;
        maxAvgHappiness = avgHappiness;

        path = tempPath;
        reverse(path.begin(), path.end());
      }
    } else {
        for (auto e : pre[name])
            dfs(e, sumHappiness + happiness[e]);
    }
    tempPath.pop_back();
}

int main() {
    int n, k;
    string start, end = "ROM";
    cin >> n >> k >> start;

    // 读取每个城市的快乐值
    for (int i = 0; i < n - 1; ++i) {
        int happy;
        string name;
        cin >> name >> happy;
        happiness[name] = happy;
    }

    // 读取所有的道路
    for (int i = 0; i < k; ++i) {
        int cost;
        string c1, c2;
        
        cin >> c1 >> c2 >> cost;

        graph[c1].push_back({ c2, cost });
        graph[c2].push_back({ c1, cost });
    }

    dijkstra(start);  // dijkstra找出所有最短路径
    dfs(end, happiness[end]);       // dfs选出快乐值最大且平均快乐值尽可能大的最短路径

    cout << pathCnt["ROM"] << " " << dist["ROM"] << " "
         << maxSumHappiness << " " << int(maxAvgHappiness) << "\n";

    for (auto iter = path.begin(); iter != path.end(); ++iter) {
        cout << *iter;
        if (iter + 1 != path.end()) cout << "->";
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值