题目详情
There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given NN distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?
For example, given N = 5 N=5 N=5 and the numbers 1, 3, 2, 4, and 5. We have:
- 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
- 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
- 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
- and for the similar reason, 4 and 5 could also be the pivot.
Hence in total there are 3 pivot candidates.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N N N ( ≤ 1 0 5 \le 10^5 ≤105). Then the next line contains N N N distinct positive integers no larger than 1 0 9 10^9 109. The numbers in a line are separated by spaces.
Output Specification:
For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:
5
1 3 2 4 5
Sample Output:
3
1 4 5
题解
给一个经过分割的数组,判断分割前可能的主元都有哪些。所谓分割就是快排中的Partition
计算每个位置左侧最大的数和右侧最小的数,和这个数本身相比较,来判断是否满足主元的条件。
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int arr[100005];
int lMax[100005];
int rMin[100005];
int main() {
// 读入
int n;
cin >> n;
for (int i = 0; i < n; ++i)
cin >> arr[i];
// 计算每个位置(包括)的左边最大的数
lMax[0] = arr[0];
for (int i = 1; i < n; ++i)
lMax[i] = max(arr[i], lMax[i - 1]);
// 计算每个位置(包括)的右边最小的数
if (n - 1 > 0) rMin[n - 1] = arr[n - 1];
for (int i = n - 2; i >= 0; --i)
rMin[i] = min(arr[i], rMin[i + 1]);
// 计算可能的主元
vector<int> priv;
if (arr[0] <= rMin[1]) priv.push_back(arr[0]);
if (n - 2 > 0 && arr[n - 1] >= lMax[n - 2]) priv.push_back(arr[n - 1]);
for (int i = 1; i < n - 1; ++i)
if (arr[i] >= lMax[i - 1] && arr[i] <= rMin[i + 1])
priv.push_back(arr[i]);
// 排序后输出
sort(priv.begin(), priv.end());
int sz = priv.size();
cout << sz << '\n';
for (int i = 0; i < sz; ++i) {
cout << priv[i];
if (i != sz - 1) cout << ' ';
}
cout << '\n';
}