EOJ1855 贪心+优先队列

题目:

Expedition

Time Limit:1000MS Memory Limit:30000KB
Total Submit:529 Accepted:157

Description

A group of cows grabbed a truck and ventured on an expedition deep into thejungle. Being rather poor drivers, the cows unfortunately managed to run over arock and puncture the truck's fuel tank. The truck now leaks one unit of fuelevery unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than1,000,000 units distant) down a long, winding road. On this road, between thetown and the current location of the truck, there are N (1 <= N <=10,000) fuel stops where the cows can stop to acquire additional fuel (1..100units at each stop).

The jungle is a dangerous place for humans and is especially dangerous forcows. Therefore, the cows want to make the minimum possible number of stops forfuel on the way to the town. Fortunately, the capacity of the fuel tank ontheir truck is so large that there is effectively no limit to the amount offuel it can hold. The truck is currently L units away from the town and has Punits of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cowscannot reach the town at all.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Each line contains two space-separated integers describing afuel stop: The first integer is the distance from the town to the stop; thesecond is the amount of fuel available at that stop.

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary toreach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint
INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Alongthe road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town(so these are initially at distances 21, 20, 14, and 10 from the truck). Thesefuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stopto acquire 5 more units of fuel, then drive to the town.

 

分析:

贪心+优先队列。要使每次加油次数最少,则要在每次必须加油才能到达下一站点时选择之前所有站点中油量最多的(用priority_queue)实现比较简单。注意把重点看成一个站点(在这里错了两次才想到),其含油量为零。实时计算车内的油,若到达某一站点车内油量为负,说明之前需要加油,不断加上队首元素,直至油量为非负,若队空任然无法使油量非负,则说明不能到达该站点。

 

 

代码:

#include <iostream>

#include <cstdio>

#include <cstring>

#include <cmath>

#include <string>

#include <vector>

#include <map>

#include <algorithm>

#include <queue>

 

using namespace std;

 

struct St                                                           //站点

{

   int pos,ful;

}st[10001];

 

bool cmp(const St a,const St b)

{

   return a.pos<b.pos;

}

 

int main()

{

   int n,i;

   cin>>n;

   for(i=0;i<n;++i)

    {

       scanf("%d%d",&st[i].pos,&st[i].ful);

    }

   st[n].pos=0;st[n].ful=0;

   sort(st,st+n+1,cmp);

   int dis,gas;

   scanf("%d%d",&dis,&gas);

   priority_queue<int> q;

   int cnt=0;

   for(i=n;i>=0;--i)

    {

       gas=gas-(dis-st[i].pos);

       dis=st[i].pos;

        if(gas<0)

       {

           while(gas<0 && !q.empty())

           {

                gas+=q.top();

                q.pop();

                ++cnt;

           }

           if(gas<0)

           {

               cout<<"-1"<<endl;

                return 0;

           }

       }

       q.push(st[i].ful);

    }

   cout<<cnt<<endl;

   return 0;

}

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值