eoj1857

push!

Time Limit:1000MSMemory Limit:30000KB
Total Submit:124Accepted:67

Description

Mr. Schwarz was a famous powerful pro wrestler. He starts a part time job as a warehouseman. His task is to move a cargo to a goal by repeatedly pushing the cargo in the warehouse, of course, without breaking the walls and the pillars of the warehouse.

There may be some pillars in the warehouse. Except for the locations of the pillars, the floor of the warehouse is paved with square tiles whose size fits with the cargo. Each pillar occupies the same area as a tile.


Initially, the cargo is on the center of a tile. With one push, he can move the cargo onto the center of an adjacent tile if he is in proper position. The tile onto which he will move the cargo must be one of (at most) four tiles (i.e., east, west, north or south) adjacent to the tile where the cargo is present.

To push, he must also be on the tile adjacent to the present tile. He can only push the cargo in the same direction as he faces to it and he cannot pull it. So, when the cargo is on the tile next to a wall (or a pillar), he can only move it along the wall (or the pillar). Furthermore, once he places it on a corner tile, he cannot move it anymore.

He can change his position, if there is a path to the position without obstacles (such as the cargo and pillars) in the way. The goal is not an obstacle. In addition, he can move only in the four directions (i.e., east, west, north or south) and change his direction only at the center of a tile.

As he is not so young, he wants to save his energy by keeping the number of required pushes as small as possible. But he does not mind the count of his pedometer, because walking is very light exercise for him.

Your job is to write a program that outputs the minimum number of pushes required to move the cargo to the goal, if ever possible.

Input

The input consists of multiple maps, each representing the size and the arrangement of the warehouse. A map is given in the following format.

w h
d11 d12 d13 ... d1w
d21 d22 d23 ... d2w
. . .
dh1 dh2 dh3 ... dhw

The integers w and h are the lengths of the two sides of the floor of the warehouse in terms of widths of floor tiles. w and h are less than or equal to 7. The integer dij represents what is initially on the corresponding floor area in the following way.

0: nothing (simply a .oor tile)
1: a pillar
2: the cargo
3: the goal
4: the warehouseman (Mr. Schwarz)

Each of the integers 2, 3 and 4 appears exactly once as dij in the map. Integer numbers in an input line are separated by at least one space character. The end of the input is indicated by a line containing two zeros.

Output

For each map, your program should output a line containing the minimum number of pushes. If the cargo cannot be moved to the goal, -1 should be output instead.

Sample Input

5 5
0 0 0 0 0
4 2 0 1 1
0 1 0 0 0
1 0 0 0 3
1 0 0 0 0
5 3
4 0 0 0 0
2 0 0 0 0
0 0 0 0 3
7 5
1 1 4 1 0 0 0
1 1 2 1 0 0 0
3 0 0 0 0 0 0
0 1 0 1 0 0 0
0 0 0 1 0 0 0
6 6
0 0 0 0 0 3
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 2 0 0 0 0
4 0 0 0 0 0
0 0

Sample Output

5
-1
11

8


题目:EOJ1857

 

题目分析:用两层bfs,主bfs表示箱子到达目的点的最短路径,若用dx[]={-1,1,0,0},dy[]={0,0,-1,1}表示移动方向,now表示当前节点,next表示下一节点(next.x=now.x+dx[i];next.y=now.y+dy[i];),若能从now访问到next节点需满足条件:搬运工能移动到点(now.x-dx[i],now-dy[i]),则可用bfs_man另一个bfs函数判断此条件能否成立。同样,应注意到对箱子来说每个点可从四个方向访问。

 

AC代码:

#include <iostream>

#include <cstdio>

#include <cstring>

#include <cmath>

#include <queue>

 

using namespace std;

int map[10][10];

boolvisited[10][10][4],visited_man[10][10];

int dx[]={-1,1,0,0},dy[]={0,0,-1,1};

 

struct Node{

   int x,y,step,x_man,y_man;

   Node(){x=y=step=x_man=y_man=0;}

};

 

bool bfs_man(int x,int y,int x_goal,inty_goal,int w,int h,int x_full,int y_full){

   Node now,next;

   now.x=x;now.y=y;

   memset(visited_man,false,sizeof(visited_man));

   visited_man[x][y]=true;

   queue<Node> q;

   q.push(now);

   while(!q.empty()){

       now=q.front();

       q.pop();

       if(now.x==x_goal && now.y==y_goal)

           return true;

       for(int i=0;i<4;++i){

           next.x=now.x+dx[i];next.y=now.y+dy[i];

           if(next.x>=0 && next.x<h && next.y>=0&& next.y<w && !visited_man[next.x][next.y] &&map[next.x][next.y]!=1 && (next.x!=x_full || next.y!=y_full)){

                if(next.x==x_goal &&next.y==y_goal)

                    return true;

                q.push(next);

               visited_man[next.x][next.y]=true;

           }

       }

    }

   return false;

}

 

int bfs(int x,int y,int x_goal,inty_goal,int x_man,int y_man,int w,int h){

   Node now,next;

   now.x=x;now.y=y;

   now.x_man=x_man;now.y_man=y_man;

   queue<Node> q;

   q.push(now);

   while(!q.empty()){

       now=q.front();

       q.pop();

       for(int i=0;i<4;++i){

           next.x=now.x+dx[i];

           next.y=now.y+dy[i];

           next.x_man=now.x;

           next.y_man=now.y;

           next.step=now.step+1;

           int to_x=now.x-dx[i],to_y=now.y-dy[i];

 

           memset(visited_man,false,sizeof(visited_man));

           bool tem=bfs_man(now.x_man,now.y_man,to_x,to_y,w,h,now.x,now.y);

           if(next.x>=0 && next.x<h && next.y>=0&& next.y<w && !visited[next.x][next.y][i] &&map[next.x][next.y]!=1

               && tem ){

                if(next.x==x_goal &&next.y==y_goal){

                    return next.step;

                }

                q.push(next);

                visited[next.x][next.y][i]=true;

           }

       }

    }

   return -1;

}

 

int main()

{

   int w,h,i,j,x,y,x_man,y_man,x_goal,y_goal;

   while(scanf("%d%d",&w,&h),h||w){

       memset(visited,false,sizeof(visited));

       memset(visited_man,false,sizeof(visited_man));

       for(i=0;i<h;++i){

           for(j=0;j<w;++j){

               scanf("%d",&map[i][j]);

                if(map[i][j]==2){

                    x=i;y=j;

                }

                if(map[i][j]==4){

                    x_man=i;y_man=j;

                }

                if(map[i][j]==3){

                    x_goal=i;y_goal=j;

                }

           }

       }

//       cout<<bfs_man(x_man,y_man,x_goal,y_goal,w,h,x,y)<<endl;

       int ans=bfs(x,y,x_goal,y_goal,x_man,y_man,w,h);

       printf("%d\n",ans);

    }

   return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值