HDU-1509Windows Message Queue(优先队列)

Windows Message Queue(优先队列)

题目本身没有难度,入门级的优先队列,需要 注意的是排序规则的写法,之前是按照优先级排序,如果优先级相等,按入队次序排序,但是wa了几发,改了下排序改成按入队次序排序然后优先级不等按优先级排序才过了

  • 题目
    Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

  • 输入
    There’s only one test case in the input. Each line is a command, “GET” or “PUT”, which means getting message or putting message. If the command is “PUT”, there’re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

  • 输出
    For each “GET” command, output the command getting from the message queue with the name and parameter in one line. If there’s no message in the queue, output “EMPTY QUEUE!”. There’s no output for “PUT” command.

  • 样例输入
    GET
    PUT msg1 10 5
    PUT msg2 10 4
    GET
    GET
    GET

  • 样例输出
    EMPTY QUEUE!
    msg2 10
    msg1 10
    EMPTY QUEUE!

#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
string me;
struct node {
	string str;
	int can, you, id;
}window;
struct cmp {
	bool operator()(const node& n1, const node& n2){
		if (n1.you != n2.you) {
			return n1.you > n2.you;
		}
		return n1.id > n2.id;
	}
};
int main() {
	int sum = 1;
	priority_queue<node, vector<node>, cmp>que;
	while (cin >> me) {
		if (me == "PUT") {
			cin >> window.str >> window.can >> window.you;
			window.id = sum;
			sum++;
			que.push(window);
		}
		else {
			if (que.empty()) {
				cout << "EMPTY QUEUE!" << endl;
			}
			else {
				window = que.top();
				cout << window.str << ' ' << window.can << endl;
				que.pop();
			}
		}
	}
	return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值