A Secret
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 256000/256000 K (Java/Others)
Total Submission(s): 1766 Accepted Submission(s): 653
Problem Description
Today is the birthday of SF,so VS gives two strings S1,S2 to SF as a present,which have a big secret.SF is interested in this secret and ask VS how to get it.There are the things that VS tell:
Suffix(S2,i) = S2[i…len].Ni is the times that Suffix(S2,i) occurs in S1 and Li is the length of Suffix(S2,i).Then the secret is the sum of the product of Ni and Li.
Now SF wants you to help him find the secret.The answer may be very large, so the answer should mod 1000000007.
Input
Input contains multiple cases.
The first line contains an integer T,the number of cases.Then following T cases.
Each test case contains two lines.The first line contains a string S1.The second line contains a string S2.
1<=T<=10.1<=|S1|,|S2|<=1e6.S1 and S2 only consist of lowercase ,uppercase letter.
Output
For each test case,output a single line containing a integer,the answer of test case.
The answer may be very large, so the answer should mod 1e9+7.
Sample Input
2
aaaaa
aa
abababab
aba
Sample Output
13
19
Hint
case 2:
Suffix(S2,1) = “aba”,
Suffix(S2,2) = “ba”,
Suffix(S2,3) = “a”.
N1 = 3,
N2 = 3,
N3 = 4.
L1 = 3,
L2 = 2,
L3 = 1.
ans = (3*3+3*2+4*1)%1000000007.
1.首先将两个字符串倒过来,然后再最末尾各加一个不同的字符。
2.考虑KMP匹配的过程中,每拓展一个长度的匹配,就会多匹配长度的价值。
3.如果我们失败匹配了,j=next【j】之后,之前匹配上的部分还需要加上len*(len+1)/2的价值。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
#define ll __int64
int nextt[1000007];
char a[1512345];
char b[1512345];
int lena, lenb;
ll ans;
ll mod = 1e9 + 7;
void getnext()//子串的next数组
{
int i = 0, j = -1;
nextt[0] = -1;
while(i<lenb)
{
if(j==-1||b[i]==b[j])
{
i++;
j++;
nextt[i]=j;
}
else
j=nextt[j];
}
}
void KMP()
{
int i=0,j=0;
getnext();
while(i<lena)
{
if(j==-1||a[i]==b[j])
{
ans+=j+1;//
ans%=mod;
i++;
j++;
}
else
{
if(j==0)i++;
else
{
j=nextt[j];
ans+=(ll)j*(j+1)/2;//
ans%=mod;
}
}
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
ans=0;
scanf("%s%s",a,b);
lena=strlen(a);
lenb=strlen(b);
reverse(a,a+lena);
reverse(b,b+lenb);
a[lena]='Y';
lena++;
a[lena]='\0';
b[lenb]='Z';
lenb++;
b[lenb]='\0';
KMP();
printf("%I64d\n",ans);
}
}