hdu 1385 Minimum Transport Cost(最短路+记录路径)

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9091    Accepted Submission(s): 2398


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
 

Source



题意要求计算任意两点的最短路程加中转费用之和,并记录起路径,有相同的取路径字典序最小的

用Floyd算,同时学习了一波记录路径的方法

PS:最坑的是我写了while(scanf("%d",&n)!=EOF&n)   少了一个& 所以一直WA,找了半天才发现

代码:
<pre name="code" class="cpp">#include<stdio.h>
#include<iostream>
#include<string>
#include<string.h>
#include<cstdlib>
#include<algorithm>
#include<map>
#include<cmath>
#include<stack>
#include<queue>
#include<set>
#include<vector>
#define F first
#define S second
#define PI acos(-1.0)
#define E  exp(1.0)
#define INF 0xFFFFFFF
#define MAX -INF
#define len(a) (__int64)strlen(a)
#define mem0(a) (memset(a,0,sizeof(a)))
#define mem1(a) (memset(a,-1,sizeof(a)))
using namespace std;
__int64 gcd(__int64 a, __int64 b) {
	return b ? gcd(b, a % b) : a;
}
__int64 lcm(__int64 a, __int64 b) {
	return a / gcd(a, b) * b;
}
__int64 max(__int64 a, __int64 b) {
	return a > b ? a : b;
}
__int64 min(__int64 a, __int64 b) {
	return a < b ? a : b;
}
int path[110][110], dis[110][110], n, tax[110];
void floyd() {
	for (int i = 1; i <= n; i++)
		for (int j = 1; j <= n; j++)
			path[i][j] = j;
	for (int k = 1; k <= n; k++) {
		for (int i = 1; i <= n; i++) {
			for (int j = 1; j <= n; j++) {
				int temp = dis[i][k] + dis[k][j] + tax[k];
				if (temp < dis[i][j]) {
					dis[i][j] = temp;
					path[i][j] = path[i][k];
				} else if (temp == dis[i][j]) {
					if (path[i][j] > path[i][k])
						path[i][j] = path[i][k];
				}
			}
		}
	}
}
int main() {
// freopen("in.txt","r",stdin);
// freopen("out.txt","w",stdout);
	int w, a, b;
	while (scanf("%d", &n) != EOF && n) {
		for (int i = 1; i <= n; i++)
			for (int j = 1; j <= n; j++) {
				scanf("%d", &w);
				if (w == -1)
					dis[i][j] = 999999;
				else
					dis[i][j] = w;
			}
		for (int i = 1; i <= n; i++) {
			scanf("%d", &tax[i]);
		}
		floyd();
		while (scanf("%d%d", &a, &b) != EOF) {
			if (a == -1 && b == -1)
				break;
			printf("From %d to %d :\n", a, b);
			printf("Path: %d", a);
			int t = a;
			while (t != b) {
				printf("-->%d", path[t][b]);
				t = path[t][b];
			}
			printf("\n");
			printf("Total cost : %d\n\n", dis[a][b]);
		}
	}
	return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值