链表(裸题)

Doubly Linked List  Aizu - ALDS1_3_C 

Your task is to implement a double linked list.

Write a program which performs the following operations:

  • insert x: insert an element with key x into the front of the list
  • delete x: delete the first element which has the key of x from the list
  • deleteFirst: delete the first element from the list
  • deleteLast: delete the last element from the list

Input

The input is given in the following format:

n
command
1
command2
...
commandn

In the first line, the number of operations n is given. In the following n lines, the above mentioned operations are given in the following format:

  • insert x
  • delete x
  • deleteFirst
  • deleteLast

Output

Print all the element (key) in the list after the given operations. Two consequtive keys should be separated by a single space.

Constraints

  • The number of operations ≤ 2,000,000
  • The number of delete operations ≤ 20
  • 0 ≤ value of a key ≤ 109
  • the number of elements in the list does not exceed 106

Sample Input 1

7
insert 5
insert 2
insert 3
insert 1
delete 3
insert 6
delete 5

Sample Output 1

6 1 2

Sample Input 2

9
insert 5
insert 2
insert 3
insert 1
delete 3
insert 6
delete 5
deleteFirst
deleteLast

Sample Output 2

1

题目意思是指写一个支持插入元素,删除特定元素,删除头元素,删除尾元素,打印整条链表操作的链表。

下面是初始化操作:

然后是各种普通操作顺序:

在理解后就可以看代码了,本题为了快速的删除尾,所使用的是环型链表,上代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;

struct Node{
  int key;
  Node *prev;
  Node *next;
};

Node *head;

Node *listSearch(int key){
  Node *cur = head->next;
  while(cur != head && cur->key != key){
    cur = cur->next;
  }
  return cur;
}

void init(){
  head = new Node;
  head->prev = head;
  head->next = head;
}

void printlist(){
  Node *cur = head->next;
  int isf = 0;
  while(1){
    if(cur == head)break;
    if(isf++ > 0)printf(" ");
    printf("%d",cur->key);
    cur = cur->next;
  }
  printf("\n");
}

void insert(int key){
  Node *x = new Node;
  x->key = key;
  x->next = head->next;
  head->next->prev = x;
  head->next = x;
  x->prev = head;
}

void deleteNode(Node *t){
  if(t == head)return;
  t->prev->next = t->next;
  t->next->prev = t->prev;
  free(t);
}

void deleteFirst(){
  deleteNode(head->next);
}

void deleteLast(){
  deleteNode(head->prev);
}

void deletekey(int key){
  deleteNode(listSearch(key));
}

int main(){
  int key,n,i;
  char com[20];
  scanf("%d",&n);
  init();
  for(i = 0;i < n; i++){
    scanf("%s%d",com,&key);
    if(com[0] == 'i'){insert(key);}
    else if(com[0] == 'd'){
      if(strlen(com) > 6){
        if(com[6] == 'F')deleteFirst();
        else if(com[6] == 'L')deleteLast();
      }
      else{
        deletekey(key);
      }      
    }
  }
  printlist();
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值