Crazy Search

题目描述:

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5.

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions. 

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text. 

Sample Input

3 4
daababac

Sample Output

5

Hint

Huge input,scanf is recommended. 

题目解析:

纯粹的字符串hash,只不过由于数据原因需要将他们压缩,不能使用该字符再26字母中排列的位置来hash,必须非别给他们映射一个id使得hash值尽量减小,才能是空间不爆掉。

代码如下:

/*************************************************************************
    > File Name: Crazy_Search.cpp
    > Author: Frade
    > Mail: frade@vip.sina.com.cn 
    > Created Time: 2017年05月11日 星期四 15时14分14秒
 ************************************************************************/

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int Getint()
{
    char c = getchar();
    bool flag = false;
    int ans = 0;
    while(c != '-' && (c <'0' || c > '9'))c = getchar();
    if(c == '-')flag = true,c = getchar();
    while(c >= '0' && c <= '9')ans = ans*10 + c - '0',c = getchar();
    return (flag == true) ? -ans : ans;
}

const int maxn = 16000000 + 5;
const int mod = 1000000 + 7;

int n,nc;
int id[28],cnt;
char s[maxn];
bool vis[maxn];

int Get_hash(int l,int r)
{
    int tmp = 0;
    for(int i = l;i <= r; i++)
        tmp = tmp*nc + (id[s[i] - 'a']);
    return tmp;
}

int main()
{
    int ans = 0;
    n = Getint();
    nc = Getint();
    scanf("%s",s);
    int len = strlen(s);

    for(int i = 0;i < len; i++)
    {
        if(!id[s[i]-'a'])id[s[i]-'a'] = ++cnt;//映射id
        if(cnt == nc)break;
    }

    for(int i = 0;i < len-n+1; i++)
    {
        int l = i,r = i+n-1;
        int hash_key = Get_hash(l,r);
        //printf("%d\n",hash_key);
        if(!vis[hash_key])
        {
            vis[hash_key] = true;
            ans++;
        }
    }
    printf("%d\n",ans);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值