二分搜索

Binary Search

You are given a sequence of n integers S and a sequence of different q integers T. Write a program which outputs C, the number of integers in T which are also in the set S.

Input

In the first line n is given. In the second line, n integers are given. In the third line q is given. Then, in the fourth line, q integers are given.

Output

Print C in a line.

Constraints

  • Elements in S is sorted in ascending order
  • n ≤ 100000
  • q ≤ 50000
  • 0 ≤ an element in S ≤ 109
  • 0 ≤ an element in T ≤ 109

Sample Input 1

5
1 2 3 4 5
3
3 4 1

Sample Output 1

3

Sample Input 2

3
1 2 3
1
5

Sample Output 2

0

Notes

本题是一种更加快捷的查找方法,但要求查找序列一定要是有序的序列。这样才可以对半砍来分,从而达到logn的复杂度。

代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 100000 + 5;

int n,sum = 0;
int a[maxn];

bool find(int key){
  int l = 0,r = n;
  while(l < r){
    int mid = (l+r)>>1;
    if(a[mid] < key){
      l = mid+1;
    }
    else if(a[mid] > key){
      r = mid;
    }
    else{
      return true;
    }
  }
  return false;
}

int main(){
  scanf("%d",&n);
  for(int i = 0;i < n; i++){
    scanf("%d",&a[i]);
  }
  sort(a+1,a+n+1);
  int q;
  scanf("%d",&q);
  for(int i = 0;i < q; i++){
    int key;
    scanf("%d",&key);
    if(find(key)){
      sum++;
    }
  }
  printf("%d\n",sum);
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值