Tree Cutting (树形dp + 树的重心问题变形)

题目:Tree Cutting

After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses.

Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ.

Please help Bessie determine all of the barns that would be suitable to disconnect.
Input
* Line 1: A single integer, N. The barns are numbered 1..N.

* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.
Output
* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".
Sample Input
10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8
Sample Output
3
8
Hint
INPUT DETAILS:

The set of connections in the input describes a "tree": it connects all the barns together and contains no cycles.

OUTPUT DETAILS:

If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).


题意:

给一棵n个结点的树。求去掉哪个点能使得剩下的每个连通子图的节点数不超过n/2.输出满足条件的点,如果有多个这样的点,则升序输出。

输入:第一个表示有n个结点,接下来n-1行每行两个值,表示这两个结点相连接。

思路:树形dp + 树的重心问题的变形

和上一个树的重心问题很类似,考虑以now为根的子树和另一部分然后进行dp就可以了。

考虑两部分然后进行dp。

dp[i]记录拥有的最大的节点数

状态转移方程见代码。

源代码:

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cmath>
#include <iomanip>
#define maxn 10005
typedef long long ll;
using namespace std;
vector <int> tree[maxn];
int dp[maxn];
int n;
int num[maxn];//统计以i为根结点的树的节点数
int sum;
void tree_dp(int now,int father){
    num[now] = 1; //注意这里是1
    for (int i = 0; i < tree[now].size(); i++){
        if (tree[now][i] == father)
            continue;
        tree_dp(tree[now][i],now);
        num[now] += num[tree[now][i]];//记录结点数
        sum = max(sum,num[tree[now][i]]);
    }
    dp[now] = max(sum,n-num[now]);//总点数减去该点的所有子结点表示父节点的子树
}
int main(){
    while (scanf("%d",&n) != EOF){
        memset(num,0,sizeof(num));
        memset(dp,0,sizeof(dp));
        for (int i = 0; i <= n; i++)
            tree[i].clear();
        int x,y;
        for (int i = 1; i < n; i++){
            scanf("%d%d",&x,&y);
            tree[x].push_back(y);
            tree[y].push_back(x);
        }
        tree_dp(1,-1);
        int flag = 0;
        for (int i = 1; i <= n; i++){
            if (dp[i] > n/2)
                continue;
            else{
                flag = 1;
                printf("%d\n",i);
            }
        }
        if (flag == 0)
            printf("NONE\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值