Leading and Trailing ——kuangbin带你飞(数论基础)

16 篇文章 0 订阅
1 篇文章 0 订阅

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output
For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input
5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output
Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

题目链接

https://vjudge.net/contest/70017#problem/E

题目大意

求a ^ n的前三位数和后三位数

数据范围

T (≤ 1000)
n (2 ≤ n < 2^31)
k (1 ≤ k ≤ 1e7)

解题思路

数据范围大,快速幂的方法查找后三位

int last(int a,int n){
int ans = 1;
a %= 1000;
while(n){
	if(n % 2) ans =ans * a % 1000;
	n = n / 2;
	a = a * a % 1000;
	}
	return ans;
}

求前三位要用**(double ) fmod (double x,double y)**这一个函数,它的作用是x对y取余,在库函数<math.h>里。和 % 的取余不一样,% 是对整数取余,余数是整数,但是 这个函数它的余数可以是小数。
例如 fmod(2.00005,1) = 0.00005

要求 a ^ n , 我们可以把它转换成 10 ^ x 这种情况, 这样 x = n * log10(a), ,X可能是一个小数,小数部分的取值范围为 10 ^ 0 < y < 10 ^ 1 ; 由于求的是三位数为保证输出有效三位数,我们需要 + 2 也就是乘以 10^2。

求 a ^ n前三位数模板

ans = (int)pow( 10.0 , 2 + fmod(n*log10(a) , 1) );

解决代码

#include<cstdio>
#include<cmath>
//快速幂
int last(int a,int n){
int ans = 1;
a %= 1000;
while(n){
	if(n % 2) ans =ans * a % 1000;
	n = n / 2;
	a = a * a % 1000;
	}
	return ans;
}

int main()
{
int t,a,n,cnt = 1;
scanf("%d",&t);
while(t--){
	scanf("%d %d",&a,&n);
	int l,r;
    l=(int)pow( 10.0 , 2 + fmod(n*log10(a) , 1) );   
	while(l > 1000) l /= 10;
	r = last(a,n);
	printf("Case %d: %d %03d\n",cnt++,l,r);
	}
return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值