Leading and Trailing

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

题意就是求n的k次方的前三位和后三位,后三位你用快速幂就可以搞定,前三位就比较麻烦了,开始我用的while循环去弄,结果超时,后来改成字符串也弄不了。然后看了大佬的博客才明白,原来利用对数就可以把数的范围缩小,然后再用while就可以了。

#include<stdio.h>
#include<math.h>
long long int cn(long long int x, int y)
{
    long long int z=1;
    while(y)
    {
        if(y%2)
            z=z*x%1000;
        x=x*x%1000;
        y=y/2;
    }
    return z;
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int i=1; i<=t; i++)
    {
        int n,k;
        scanf("%d%d",&n,&k);
        int l=k*log10(n);
        double t=pow(10,1.0*k*log10(n)-l);
        while(t<100)
            t*=10;
        int ans=t;
        int sum=cn(n,k);
        printf("Case %d: %d %03d\n",i,ans,sum);
    }
    return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值