HDU 1150 Machine Schedule 二分匹配

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8191    Accepted Submission(s): 4094


Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 
 

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 

Output
The output should be one integer per line, which means the minimal times of restarting machine.
 

Sample Input
  
  
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

Sample Output
  
  
3


学长手动翻译的题意:在一个工厂,有两台机器A, B生产产品。A机器有n种工作模式(模式0,模式1....模式n-1)。B机器有m种工作模式(模式0,模式1....模式m-1)。现在要加工k个产品。每个产品可以由两台机器特定的模式生产。例如:产品0,可以由A机器在3号模式或B机器4号模式生产。   两台机器初始模式都在模式0,但是,这两台机器不是很先进,如果需要切换模式,只能由人手工切换模式,手工切换可以切换到任意模式。求加工完k个产品需要切换模式的最少次数。(生产产品的顺序可以任意)

裸的二分匹配

二分匹配:给出一个二分图,找一个边数最大的匹配,即选最多的边,使得任意两条选中的边均没有公共点。如果所有点都是匹配点,称这个匹配是完美匹配。

二分匹配就是不断寻找增广路的过程。

其实我只是想记录一个模版

CODE

#include <bits/stdc++.h>
using namespace std;
const int N = 1000+10;
struct node{
    int en,next;
}E[N];
int n,m,k;
int top;      ///邻接表用
int ans;      ///存答案
int head[N];  ///邻接表头结点
int match[N]; ///保存已匹配的点
bool vis[N];  ///dfs标记数组

void Init(){
    top = ans = 0;
    for(int i = 0;i < N;i++){
        head[i] = match[i] = -1;
    }
}

void add(int u,int v){   ///邻接表加边
    E[top].en = v;
    E[top].next = head[u];
    head[u] = top++;
}

bool dfs(int u){
    for(int i = head[u];i != -1;i = E[i].next){
        int v = E[i].en;
        if(vis[v]) continue;
        vis[v] = true;
        if(match[v] == -1 || dfs(match[v])){ ///寻找增光路
            match[v] = u;
            return true;
        }
    }
    return false;
}

void xyl(){
    for(int i = 0;i < n;i++){
        memset(vis,false,sizeof vis);
        if(dfs(i))   ///每个点都要dfs
            ans++;
    }
    printf("%d\n",ans);
}

int main(void)
{
    while(scanf("%d",&n) && n){
        Init();
        scanf("%d%d",&m,&k);
        for(int i = 1;i <= k;i++){
            int t,x,y;
            scanf("%d%d%d",&t,&x,&y);
            if(x == 0 || y == 0) continue; ///0点的边不计入答案
            add(x,y);
        }
        xyl();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值