[POJ1325]机器调度 做题笔记

18 篇文章 0 订阅
9 篇文章 0 订阅

Description

As we all know, machine scheduling is a very classical problem in
computer science and has been studied for a very long history.
Scheduling problems differ widely in the nature of the constraints
that must be satisfied and the type of schedule desired. Here we
consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working
modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine
B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the
beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the
two machines in particular mode. For example, job 0 can either be
processed in machine A at mode_3 or in machine B at mode_4, job 1 can
either be processed in machine A at mode_2 or in machine B at mode_4,
and so on. Thus, for job i, the constraint can be represent as a
triple (i, x, y), which means it can be processed either in machine A
at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine’s
working mode from time to time, but unfortunately, the machine’s
working mode can only be changed by restarting it manually. By
changing the sequence of the jobs and assigning each job to a suitable
machine, please write a program to minimize the times of restarting
machines.

Input

The input file for this program consists of several configurations.
The first line of one configuration contains three positive integers:
n, m (n, m < 100) and k (k < 1000). The following k lines give the
constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output

The output should be one integer per line, which means the minimal
times of restarting machine.

Sample Input
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8
3 3 9 4 3 0

Sample Output
3

二分图的点覆盖数=匹配数
直接根据题目描述连边,根据二分图的点覆盖数=匹配数,求最大匹配即可
匈牙利算法邻接矩阵:

#include <cstdio>
#include <algorithm>
#include <cstring>
#define maxn 105
int nx,ny;
int jobnum;
int g[maxn][maxn];
int ans;
int sx[maxn],sy[maxn];
int cx[maxn],cy[maxn];
int path (int u) {
    sx[u]=1;
    int v;
    for (v=1;v<=ny;v++) {
        if ( (g[u][v]>0) && (!sy[v]) ) {
            sy[v]=1;
            if (!cy[v]||path(cy[v])) {
                cx[u]=v;cy[v]=u;
                return 1;
            }
        }
    }
    return 0;
}

int solve () {
    ans=0;
    int i;
    memset(cx,0,sizeof(cx));
    memset(cy,0,sizeof(cy));
    for (i=1;i<=nx;i++) {
        if (!cx[i]) {
            memset(sx,0,sizeof(sx));
            memset(sy,0,sizeof(sy));
            ans+=path(i);
        }
    }
    return 0;
}

int main () {
    int i,j,k,m;
    while ( scanf("%d",&nx) ) {
        if (nx==0) break;
        scanf("%d%d",&ny,&jobnum);
        memset(g,0,sizeof(g));
        for (k=0;k<jobnum;k++) {
            scanf("%d%d%d",&m,&i,&j);
            g[i][j]=1;
        }
        solve();
        printf("%d\n",ans);
    }
    return 0;
}

匈牙利算法邻接表:

#include <cstdio>
#include <algorithm>
#include <cstring>
const int N=500;
const int M=4000;
int nx,ny,m,tot=1,ans=0;
int head[N],ver[M],edge[M],next[M];
int cx[N],cy[N];
int sx[N],sy[N];

void add (int u,int v) {
    ver[++tot]=v;next[tot]=head[u];head[u]=tot;
} 

int path (int u) {
    sx[u]=1;int v;
    for (int i=head[u];i;i=next[i]) {
        if (!sy[v=ver[i]]) {
            sy[v]=1;
            if (!cy[v]||path(cy[v])) {
                cx[u]=v;cy[v]=u;
                return 1;
            }
        }
    }
    return 0;
}

void solve () {
    ans=0;
    memset(cx,0,sizeof(cx));
    memset(cy,0,sizeof(cy));
    for (int i=1;i<=nx;i++) 
        if (!cx[i]) {
            memset(sx,0,sizeof(sx));
            memset(sy,0,sizeof(sy));
            ans+=path(i);
        }
}

int main () {
    int tmp,x,y;
    while (scanf("%d",&nx)) {
        if (!nx) break;
        tot=1;memset(head,0,sizeof(head));
        scanf("%d%d",&ny,&m);
        for (int i=1;i<=m;i++) {
            scanf("%d%d%d",&tmp,&x,&y);
            if (x&&y) add(x,y); //邻接表一定要删掉连到0上的边!!
        }
        solve();
        printf("%d\n",ans);
    }
    return 0;
}

网络流:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
using namespace std;
const int inf=0x3fffffff,N=500,M=2000;
int d[N],head[N],ver[M<<1],edge[M<<1],Next[M<<1];
int nx,ny,num,s,t,tot=1,maxflow=0;

void add (int u,int v,int cap=1) {
    ver[++tot]=v;edge[tot]=cap;Next[tot]=head[u];head[u]=tot;
    ver[++tot]=u;edge[tot]=0;  Next[tot]=head[v];head[v]=tot;
}

bool bfs () {
    memset(d,0,sizeof(d));
    queue<int> q;
    q.push(s); d[s]=1;
    while (!q.empty()) {
        int x=q.front(); q.pop();
        for (int i=head[x];i;i=Next[i]) 
            if (edge[i] && d[ver[i]]==0) {
                q.push(ver[i]);
                d[ver[i]]=d[x]+1;
                if (ver[i]==t) return true;
            }
    }
    return false;
}

int dinic (int x,int f) {
    if (x==t) return f;
    int rest=f,now;
    for (int i=head[x];i&&rest;i=Next[i])
        if (edge[i]&&d[ver[i]]==d[x]+1) {
            now=dinic(ver[i],min(rest,edge[i]));
            if (!now) d[ver[i]]=0;
            edge[i]-=now;
            edge[i^1]+=now;
            rest-=now;
        }
    return f-rest;
}

int main () {
    int tmp,x,y;
    while ( scanf("%d",&nx) ) {
        if (!nx) break;
        maxflow=0;tot=1;
        memset(head,0,sizeof(head));
        scanf("%d%d",&ny,&num);
        s=0;t=nx+ny+1;
        for (int i=1;i<=num;i++) {
            scanf("%d%d%d",&tmp,&x,&y);
            if (x&&y) add(x,nx+y);
        }
        for (int i=1;i<=nx-1;i++) add(s,i);
        for (int i=nx+1;i<nx+ny;i++) add(i,t);
        while (bfs())
            while (tmp=dinic(s,inf)) maxflow+=tmp;
        printf("%d\n",maxflow);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值