1sting

1sting
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u


Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get. 
 
Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200. 
 
Output
The output contain n lines, each line output the number of result you can get . 
 
Sample Input
3
1
11
11111 
 
Sample Output
1
2


/*这道乍一看就是简单的fib数列问题,嘿嘿,如果你真的这样想的话你就大错特错了,
即使你使用long long依然会报错,所以哈,只能用大数思想了*/
#include<stdio.h>
#include<string.h>
int main()
{
    int t;
    scanf("%d",&t);
    getchar();
    while (t--)
    {
        int a[210][100]={0},i,j,lens;		//二维数组每一位都赋初始值为0,这个很重要,后面要用
        a[1][0]=1;
        a[2][0]=2;
        for (i=3;i<210;i++)			//外层控制是第几个fib数列的数
        {
            int c=0;				//c用来保留进位
            for (j=0;j<50;j++)
            {
                a[i][j]=(a[i-1][j]+a[i-2][j]+c)%10;		//二维数组的第二维用来储存fib数列的每个数的每一位
                c=(a[i-1][j]+a[i-2][j]+c)/10;
            }
        }
        char s[210];
        scanf("%s",s);
        lens=strlen(s);
        int flag=0;
        for (j=49;j>0;j--)
        {
            if (a[lens][j]==0&&!flag)		//用flag标记没有用到的空位0
                continue;
            flag=1;
            printf("%d",a[lens][j]);
        }
        printf("%d\n",a[lens][j]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值