1sting(JAVA大数+ 递推)

1sting
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6264 Accepted Submission(s): 2428

Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.

Output
The output contain n lines, each line output the number of result you can get .

Sample Input

3
1
11
11111

Sample Output

1
2
8

//本题就是一个递推题 只是结果比较大所以需要JAVA大数
题意是相邻两个1可以变成一个2 问一共有多少种方法
我们可以这么想序列长度为n 可以看成由f[n-1] + 1组成 或者 f[n-2] +11(这两个11可以变成2)
所以一共有f[n-1] + f[n-2]种
即递推公式为:
import java.math.BigInteger;
import java.util.Scanner;

public class Main1865 {
public static void main(String[] args) {
int ncase;
Scanner cin = new Scanner(System.in);
ncase = cin.nextInt();
BigInteger[] f = new BigInteger[207];
f[1] = BigInteger.ONE;
f[2] = BigInteger.ONE.add(f[1]);
for (int i = 3; i <= 200; i++)
f[i] = f[i - 1].add(f[i - 2]);
while (ncase– > 0) {
String str = cin.next();
System.out.println(f[str.length()]);
}

}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值