HDU 1865 1sting

Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 
Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 
Output
The output contain n lines, each line output the number of result you can get .
 
Sample Input
  
  
3 1 11 11111
 
Sample Output
  
  
1 2 8
高精度 斐波那契数列
#include<iostream>
#include<string.h>
using namespace std;
int a[201][101]={0};
int main()
{
	int n,i,j,l,p;
	char s[200];
	a[1][100]=1;
	a[2][100]=2;
	for(i=3;i<=200;i++)
		for(j=100;j>=0;j--)
		{
			a[i][j]+=a[i-1][j]+a[i-2][j];
			if(a[i][j]>=10)
			{
				a[i][j-1]+=a[i][j]/10;
				a[i][j]=a[i][j]%10;
			}
		}
		cin>>n;
		while(n--)
		{
			cin>>s;
			l=strlen(s);
			for(j=0;j<=100;j++)
				if(a[l][j]!=0)
					break;
				p=j;
			for(j=p;j<=100;j++)
				cout<<a[l][j];
			cout<<endl;
		}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值