杭电oj 1001

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050

求和
输入n,求1+2+3+…+n
直接用求和公式
要注意的是输入的数能否被2整除,因为整型会自动去掉小数点后的数
还有最后需要两个/n
仔细看题目的输出
1和5050中有一个空行

#include <stdio.h>
int main(void)
{
    int a, sum;
    while(~scanf("%d", &a))
    {
        if(a % 2 == 0)sum = a/2*(a + 1);
        else sum = (a + 1)/2*a;
        printf("%d\n\n",sum);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值