两题连通性

很早以前做的两道题,直接套了两个模板。
关于模板,简单整理了一下。


UVa796

In a computer network a link L, which interconnects two servers, is considered critical if there are at
least two servers A and B such that all network interconnection paths between A and B pass through L.
Removing a critical link generates two disjoint sub–networks such that any two servers of a sub–network
are interconnected. For example, the network shown in figure 1 has three critical links that are marked
bold: 0 - 1, 3 - 4 and 6 - 7.
It is known that:
1. the connection links are bi–directional;
2. a server is not directly connected to itself;
3. two servers are interconnected if they are directly connected or if they are interconnected with
the same server;
4. the network can have stand–alone sub–networks.
Write a program that finds all critical links of a given computer network.
Input
The program reads sets of data from a text file. Each data set specifies the structure of a network and
has the format:
no of servers
server0 (no of direct connections) connected server … connected server

serverno of servers (no of direct connections) connected server … connected server
The first line contains a positive integer no of servers(possibly 0) which is the number of network
servers. The next no of servers lines, one for each server in the network, are randomly ordered and
show the way servers are connected. The line corresponding to serverk, 0 ≤ k ≤ no of servers − 1,
specifies the number of direct connections of serverk and the servers which are directly connected to
serverk. Servers are represented by integers from 0 to no of servers − 1. Input data are correct. The
first data set from sample input below corresponds to the network in figure 1, while the second data
set specifies an empty network.
Output
The result of the program is on standard output. For each data set the program prints the number of
critical links and the critical links, one link per line, starting from the beginning of the line, as shown
in the sample output below. The links are listed in ascending order according to their first element.
The output for the data set is followed by an empty line.
Sample Input
8
0 (1) 1
1 (3) 2 0 3
2 (2) 1 3
3 (3) 1 2 4
4 (1) 3
7 (1) 6
6 (1) 7
5 (0)
0
Sample Output
3 critical links
0 - 1
3 - 4
6 - 7
0 critical links

/*
 *UVA 796
 *Time 0
 *用邻接矩阵表示
 *求割边
*/
#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 1002;
bool Map[MAXN][MAXN];
struct KeyEdge{
    int u, v;
    bool operator < (const struct KeyEdge &E)const {
        if(u != E.u) return u < E.u;
        return v < E.v;
    }
}Key[MAXN];//桥
void Init(int n);
int Key_edge(int n);
void Search(int n, int *dfn, int *low, int now, int &cnt);
int main()
{
    ios_base::sync_with_stdio(false);
    cin.tie(0);
    int n;
    int u, v, x, numOfEdge;
    char c1, c2;
    while(cin>>n) {
        Init(n);
        numOfEdge = 0;
        for(int i = 0; i < n; ++i) {
            cin>>u>>c1>>x>>c2;
            for(int j = 0; j < x; ++j) {
                cin>>v;
                Map[u][v] = true;
                numOfEdge++;
            }
        }
        int criOfEdge = Key_edge(n);
        cout<<criOfEdge<<" critical links"<<endl;
        sort(Key, Key + criOfEdge);
        for(int i = 0; i < criOfEdge; ++i) {
            cout<<Key[i].u<<" - "<<Key[i].v<<endl;
        }
        cout<<endl;
    }
    return 0;
}
void Init(int n)
{
    for(int i = 0; i <= n; ++i)
        for(int j = 0; j <= n; ++j)
            Map[i][j] = false;
}
void Search(int n, int *dfn, int *low, int now, int &cnt)
{
    int i;
    for(low[now] = dfn[now], i = 0; i < n; ++i) {
        if(Map[now][i]) {
            if(!dfn[i]) {
                dfn[i] = dfn[now] + 1;
                Search(n, dfn, low, i, cnt);
                if(low[i] > dfn[now]) {
                    if(i > now) Key[cnt].u = now, Key[cnt++].v = i;
                    else Key[cnt].u = i, Key[cnt++].v = now;
                }
                if(low[i] < low[now]) low[now] = low[i];
            } else if((dfn[i] < dfn[now] - 1) && dfn[i] < low[now])
                low[now] = dfn[i];
        }
    }
}
int Key_edge(int n)
{
    int ret = 0, low[MAXN], dfn[MAXN];
    for(int i = 0; i < n; dfn[i++] = 0);
    for(int i = 0; i < n; ++i) {
        if(!dfn[i]) dfn[i] = 1, Search(n, dfn, low, i, ret);
    }
    return ret;
}

POJ1236
这题网上题解较多,如有不解可以参照其他。

/*
 *Memory 756
 *Time 16
*/
#include <iostream>
#include <stack>
using namespace std;
const int MAXN = 102;
const int MAXE = 10002;
int head[MAXN], low[MAXN], dfn[MAXN], belong[MAXN];
bool inSta[MAXN], vis[MAXN][MAXN];
int tot;
struct Edge{
    int to, next;
}edge[MAXE];
stack<int> sta;
void addEdge(int u, int v);
void slove(int n);
void Tarjan(int u, int n, int &Index, int &scc);
int main()
{
    ios_base::sync_with_stdio(false);
    cin.tie(0);
    int n, v;
    while(cin>>n) {
        tot = 0;
        for(int i = 0; i <= n; ++i) head[i] = -1;
        for(int i = 0; i <= n; ++i)
            for(int j = 0; j <= n; ++j)
                vis[i][j] = false;
        for(int i = 1; i <= n; ++i) {
            while(cin>>v && v) {
                if(vis[i][v]) continue;
                addEdge(i, v), vis[i][v] = true;
            }
        }
        slove(n);
    }
    return 0;
}
void addEdge(int u, int v)
{
    edge[tot].to = v;
    edge[tot].next = head[u];
    head[u] = tot++;
}
void slove(int n)
{
    int scc = 0, Index = 0;
    for(int i = 0; i <= n; ++i)
        low[i] = dfn[i] = belong[i] = 0, inSta[i] = false;
    for(int i = 1; i <= n; ++i)
        if(!dfn[i]) Tarjan(i, n, Index, scc);
    int in[MAXN], out[MAXN], inZero = 0, outZero = 0;
    for(int i = 0; i <= n; ++i) in[i] = out[i] = 0;
    for(int u = 1; u <= n; ++u)//统计缩点后的入度与出度
        for(int i = head[u]; i != -1; i = edge[i].next) {
            int v = edge[i].to;
            if(belong[u] != belong[v]) in[belong[v]]++, out[belong[u]]++;
        }
    for(int i = 1; i <= scc; ++i) {
        if(!in[i]) inZero++;
        if(!out[i]) outZero++;
    }
    if(scc == 1) {
        cout<<1<<endl<<0<<endl;
    } else {
        cout<<inZero<<endl<<(inZero > outZero? inZero: outZero)<<endl;
    }
}
void Tarjan(int u, int n, int &Index, int &scc)
{
    low[u] = dfn[u] = ++Index;
    sta.push(u), inSta[u] = true;
    for(int i = head[u]; i != -1; i = edge[i].next) {
        int v = edge[i].to;
        if(!dfn[v]) {
            Tarjan(v, n, Index, scc);
            if(low[u] > low[v]) low[u] = low[v];
        } else if(inSta[v]) {
            if(low[u] > dfn[v]) low[u] = dfn[v];
        }
    }
    //缩点
    if(low[u] == dfn[u]) {
        int v;
        scc++;//连通分量个数
        do{
            v = sta.top(), sta.pop();
            inSta[v] = false;
            belong[v] = scc;
        }while(u != v);
    }
}

这里有个关于连通图的习题集

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值