POJ-2488

A Knight’s Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 54055 Accepted: 18307
Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input

3
1 1
2 3
4 3
Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
Source
TUD Programming Contest 2005, Darmstadt, Germany

自从学会了用bfs+存储路径之后就看这道题,一直想着用bfs写,最后发现如果用bfs写的话,便利地图的话,一开始加入队列的点,标记之后没有办法再走了。想不到怎么解决这个问题,最后还是用bfs写的。
总体上就是dfs遍历地图+字典序+输出路径
字典序经学习是要从A1开始搜,然后按照字典序从大到小的方向搜索就可以了,不得不说这个搜索的方向一开始为难了好久,对题中的p和q,和自己定义的x,y,老是搞迷。

#include<iostream>
#include<cstring>
using namespace std;
const int maxn=27*27;
int X[8]={-1,1,-2,2,-2,2,-1,1};
int Y[8]={-2,-2,-1,-1,1,1,2,2};
int p,q,all,ans[maxn][2],cnt,flag;
bool inq[maxn][maxn];
bool test(int x,int y){
	if(x>=1&&x<=p&&y>=1&&y<=q&&inq[x][y])
	return true;
	else
	return false;
}
void dfs(int x,int y,int step)
{
	if(flag)
	return ;
	ans[step][0]=x;
	ans[step][1]=y;
	if(step==all)
	{
		flag=1;
		return ;
	}
	
	for(int i=0;i<8;i++)
	{
		int newx=x+X[i];
		int newy=y+Y[i];
		if(test(newx,newy))
		{
			inq[x][y]=false;
			dfs(newx,newy,step+1);
			inq[newx][newy]=true;
		}
	}
	return; 
}
int main()
{
	int T;
	cin>>T;
	for(int i=1;i<=T;i++)
	{
		memset(inq,true,sizeof(inq));
		cin>>p>>q;
		all=p*q;
		cnt=1;
		flag=0;
		dfs(1,1,1);
		cout<<"Scenario #"<<i<<":"<<endl;
		if(flag==0)
		{
			cout<<"impossible"<<endl;
			if(i!=T)
			cout<<endl;
			continue;
		}
		for(int j=1;j<=all;j++)
		{
			cout<<char(ans[j][1]-1+'A')<<ans[j][0];
		}
		cout<<endl;
		if(i!=T)
		cout<<endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值