problem
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.
Examples: Assume an alphabet that has symbols {A, B, C, D}
The following code is immediately decodable:
A:01 B:10 C:0010 D:0000
but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
Input
Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
Sample Input
01
10
0010
0000
9
01
10
010
0000
9
Sample Output
Set 1 is immediately decodable
Set 2 is not immediately decodable
思路
Tire 先塞长串(这样只需ins一次) 所经过的点flag++
如果不排序 就先ins 然后find 对于每个串到结尾看flag
可见,如果先塞入长串,在插入的时候就能判断当前串是否为所有串的前缀
代码示例
#include<iostream>
#include<vector>
#include<string>
#include<cstdio>
#include<algorithm>
#include<stdlib.h>
using namespace std;
const int charset=2;
struct Node{
int flag;
Node *next[charset];
Node(){
for(int i=0;i<charset;++i){
next[i]=NULL;
}
flag=0;
}
};
Node *root;
void init()
{
root=new Node();
}
void del(Node *p)
{
for(int i=0;i<charset;++i){
if(p->next[i]!=NULL) del(p->next[i]);
}
delete p;
}
vector<string> s;
bool ins(string s)
{
int len=s.length();
Node *now=root;
for(int i=0;i<len;++i){
int to=s[i]-'0';
if(now->next[to]==NULL){
now->next[to]=new Node();
}
now=now->next[to];
now->flag++;
}
if((now->flag)>1) return 0;
else return 1;
}
bool cmp(string a,string b){
return a.length()>b.length();
}
int main()
{
//ios::sync_with_stdio(false);
//freopen("in.txt","r",stdin);
//freopen("out1.txt","w",stdout);
bool flag=1;
int id=0;
init();
string tp;
while(cin>>tp){
if(tp=="9"){
sort(s.begin(),s.end(),cmp);
for(int i=0;i<s.size();++i){
//cout<<s[i]<<endl;
flag=min(flag,ins(s[i]));
}
if(flag){
cout<<"Set"<<" "<<++id<<" is immediately decodable"<<endl;
}
else{
cout<<"Set"<<" "<<++id<<" is not immediately decodable"<<endl;
}
s.clear();
del(root);
init();
flag=1;//初始默认是可以的
}
else{
// cout<<tp<<endl;
s.push_back(tp);
}
}
return 0;
}