PAT真题练习(甲级)1021 Deepest Root (25 分)

PAT真题练习(甲级)1021 Deepest Root (25 分)

原题网址: https://pintia.cn/problem-sets/994805342720868352/problems/994805482919673856

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10**4) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes’ numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

AC代码

#include<stack>
#include<queue>
#include<iostream>
#include<stdio.h>
#include<string>
#include<algorithm>
#include <memory.h>
#include<set>
#include<map>
using namespace std;
bool roads[10001][10001] = {false};
bool is_visited[10001] = {false};
int N;
std::map<int,vector<int>> levels;

// 图的深度遍历
void DFS(int index, int height){
	is_visited[index] = true;
	levels[height].push_back(index);
	for(auto i = 1;i<N + 1;i++){
		if(!is_visited[i] && roads[index][i]){
			DFS(i,height + 1);
		}
	}
}
int main(){
	cin >> N;
	for(auto i = 0; i< N-1;i++){
		int a,b;
        scanf("%d %d",&a,&b);
		roads[a][b] = roads[b][a] = true;
	}
	int count = 0;
	set<int> ids;
	int max_height = 0;
	bool flag = true;
	
	for(auto i = 1; i < N +1;i++){
		if(!is_visited[i]){
			DFS(i,1);
			count ++;
		}
	}
	// 图不连通
	if(count > 1) cout << "Error: " << count << " components";
	else{
		for(auto root:levels.rbegin()->second){
			ids.insert(root);
		}
		levels.clear();
		memset(is_visited,false,N + 1);
		DFS(*ids.begin(),1);
		for(auto root:levels.rbegin()->second){
			ids.insert(root);
		}
	}
	
	for(auto iter = ids.begin();iter!=ids.end();iter++){
		cout << *iter << endl;
	}
} 
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值