jedis使用3.x以上版本需要引入的额外包,不引入会报错

我使用连接池如果只引入jedis-3.1.0-m1.jar和commons-pool2-2.6.2.jar

会报错java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory

然后我照着提示引入了slf4j-api-1.8.0-beta4.jar

又提示 SLF4J: No SLF4J providers were found 还有两行错误没写出来

然后搜索了下发现,SLF4J本身不是一个日志库,而是一个日志库的抽象层,它必须依赖底层的日志库。

可以参考下 http://www.pianshen.com/article/4059131568/ 这篇文章

因此一般来说,需要将抽象层(例如slf4j-api-xx.jar)+中间层(例如slf4j-log4j12)+实现层(例如log4j)这三层都配置好才能保证SLF4J正常运行。

另外,有的日志库可以去掉中间层,例如slf4j-api和slf4j-simple就可以直接配合。

 

©️2020 CSDN 皮肤主题: 大白 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值