基础实验 8-1.1 单身狗(25 分)

“单身狗”是中文对于单身人士的一种爱称。本题请你从上万人的大型派对中找出落单的客人,以便给予特殊关爱。

输入格式:

输入第一行给出一个正整数 N(≤50000),是已知夫妻/伴侣的对数;随后 N 行,每行给出一对夫妻/伴侣——为方便起见,每人对应一个 ID 号,为 5 位数字(从 00000 到 99999),ID 间以空格分隔;之后给出一个正整数 M(≤10000),为参加派对的总人数;随后一行给出这 M 位客人的 ID,以空格分隔。题目保证无人重婚或脚踩两条船。

输出格式:

首先第一行输出落单客人的总人数;随后第二行按 ID 递增顺序列出落单的客人。ID 间用 1 个空格分隔,行的首尾不得有多余空格。

输入样例:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

输出样例:

5
10000 23333 44444 55555 88888

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main(){
	int spouse[131072],number,man,woman,test,count=0,temp[16384],visited[131072]={0},answer[16384],i;
	memset(spouse,-1,sizeof(spouse));
	scanf("%d",&number);
	while(number--){
		scanf("%d%d",&man,&woman);
		spouse[man]=woman;
		spouse[woman]=man;
	}
	scanf("%d",&test);
	for(i=0;i<test;i++){
		scanf("%d",temp+i);
		visited[temp[i]]=1;
	}
	for(i=0;i<test;i++)if(spouse[temp[i]]<0)answer[count++]=temp[i];
	else{
		if(!visited[spouse[temp[i]]])answer[count++]=temp[i];
	}
	sort(answer,answer+count);
	printf("%d\n",count);
	for(i=0;i<count;i++){
		if(i)printf(" ");
		printf("%05d",answer[i]);
	}
	return 0;
}

提交结果:

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值