字符串统计 HDU - 2017

对于给定的一个字符串,统计其中数字字符出现的次数。
Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。
Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。
Sample Input
2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf
Sample Output
6
9


我的代码:
#include <stdio.h>
int main()
{
int n;
char a[100]; 
while (scanf("%d",&n)!=EOF)
{
for(int j=0;j<n;j++)
{
int x=0;
scanf("%s",a);
for(int i=0;a[i]!='\0';i++)
{
     	if(a[i]<='9'&&a[i]>='0')x++;
}
    printf("%d\n",x);
}
    } 
 return 0;
 }
我的代码会出现n=2,输入两组数据之后仍然可以输入数据的情况。这不是for循环中的n失效,这是由于读入失败,n没有变,后面的字符串仍在缓冲区。例如输入asss123,这个a是字符,n读取失败,故默认仍为上面输入的2,若输入2sasss,则会显示错误。

帝的代码:
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
using namespace std;
typedef long long LL;
int main(){
    int n;
    scanf("%d",&n);
    while(n--){
        char s[1000];
        scanf("%s",s);
        int num=0;
        for(int i=0;s[i]!='\0';i++)
            if(s[i]>='0'&&s[i]<='9')
                num++;
        printf("%d\n",num);
    }
    return 0;
}

这里使用n--更清晰明了,更简洁。n--表示先操作在自减,--n表示先自减再操作。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值