字符串统计
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 60014 Accepted Submission(s): 32738
Problem Description
对于给定的一个字符串,统计其中数字字符出现的次数。
Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。
Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。
Sample Input
2 asdfasdf123123asdfasdf asdf111111111asdfasdfasdf
Sample Output
6 9
直接给出题目答案:
/*
对于给定的字符串数组,若该字符为数字;这计数器加 1;
注意:输入的时候用scanf("%s",str);或者cin>>str;不要用gets();
*/
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
char str[100000];
int main()
{
int n;
cin >> n;
while(n--)
{
int count = 0;
cin >> str;
for (int i=0; str[i];i++) //循环到文件末尾结束;
if (str[i] >= '0'&&str[i] <= '9')count++;
cout << count << endl;
memset(str, 0, sizeof(str)); //字符数组清零;
}
return 0;
}