【字符串模拟】HDU- 2054 A == B ?(一定要注意陷阱)

A == B ?

Problem Description
Give you two numbers A and B, if A is equal to B, you should print “YES”, or print “NO”.

Input
each test case contains two numbers A and B.

Output
for each case, if A is equal to B, you should print “YES”, or print “NO”.

Sample Input
1 2
2 2
3 3
4 3

Sample Output
NO
YES
YES
NO

注意:1、由于这题没有给出限制条件,因此可能会出现上千甚至上万位数的测试数据,于是必须用字符串来解题。2、然后难点就是去除前置的的0和小数点后不为零数字后面的0。
#include <stdio.h>
#include <math.h>
#include <string.h>
char* change(char *s)
{
    int l=strlen(s);
    while(s[0]=='0')
        {
            if(s[1]=='.'||l==1) break;//这里是为了把0或者0.1这样的数的第一个0给保留下来。
            else if(s[1]!='.'||l!=1)
            {
            int j=0;
            for(;s[j]!='\0';j++)
            {
                s[j]=s[j+1];
            }
            l=j-1;
            }
        }
    if(strchr(s,'.'))//如果有小数点
    {
        while(s[l-1]=='0')
        {
            s[l-1]='\0';
            l--;
        }
        if(s[l-1]=='.')//如果小数点后面全是0,要把小数点去掉。
        {
            s[l-1]='\0';
        }   
   }
   return s;
}
int main()
{
    char a[1000000],b[1000000];
    while((scanf("%s%s",a,b))!=EOF)
    {
        if((strcmp(change(a),change(b)))==0)printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值