HDU 2054 A == B?

A == B ?

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 105458    Accepted Submission(s): 16791


Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
each test case contains two numbers A and B.
 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
  
  
1 2 2 2 3 3 4 3
 

Sample Output
  
  
NO YES YES NO

对字符串进行处理,不直接进行比较


AC代码

#include<stdio.h>
#include<string.h>

char *haha(char *s);

char *haha(char *s){
	while(*s == '0')
		s++;		//去除前导0
	if(strchr(s,'.') != 0){
		int len = strlen(s);
		char *p = s + len- 1;	//指针指向字符串末尾
		while(*p == '0')
			*(p--) = 0;			//去除后导0
		if(*p == '.')
			*p = 0;				//出现1.时把.去掉
	}
	return s;
}

int main(void){
	char a[10000];
	char b[10000];

	while(scanf("%s%s",a,b) != EOF){
		if(strcmp(haha(a),haha(b)) == 0){
			puts("YES");
		}
		else
			puts("NO");
	}
	return 0;
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值