【思维】Maximum Multiple HDU - 6298 【找n=x+y+z , n被x, y, z整除, 使xyz 最大 的解是否存在】

【思维】Maximum Multiple HDU - 6298

Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.

Input
There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).

Output
For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.

Sample Input
3
1
2
3

Sample Output
-1
-1
1

题意:
n=x+y+z ,
n被x, y, z整除,
使xyz 最大
求这样的解是否存在

思路:

n = ax
n = by
n = cz

1 = 1/a + 1/b + 1/c
解方程得

  1. a = b = c = 3 abc = 27
  2. a = 2,b = 3,c = 6 abc = 36
  3. a = 2,b = c = 4 abc = 32

    显然要使得xyz最大,就要abc最小

    • 如果 n % 3 == 0,则取第一组解n * n * n / 27
      (此时第二组解一定无效,因为如果第二组解可行,那么n % 6 == 0,那一定满足n % 3 == 0,而显然第一组解得abc更小)
    • 如果 n % 4 == 0,则取第三组解n * n * n / 32

AC代码:

#include <iostream>
#include <stdio.h>
#include <math.h>

using namespace std;

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        long long n;
        scanf("%lld", &n);
        long long ans;
        if(n % 3 == 0)
            ans = n * n * n / 27;
        else if(n % 4 == 0)
            ans = n * n * n / 32;
        else
            ans = -1;
        printf("%lld\n", ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值