A - Maximum Multiple HDU - 6298

 2018 Multi-University Training Contest 1

A - Maximum Multiple 

Given an integer nn, Chiaki would like to find three positive integers xx, yy and zzsuch that: n=x+y+z, x∣nx∣n, y∣ny∣n, z∣nz∣n and xyzxyz is maximum. 

Input

There are multiple test cases. The first line of input contains an integer TT (1≤T≤1061≤T≤106), indicating the number of test cases. For each test case: 
The first line contains an integer nn (1≤n≤1061≤n≤106). 

Output

For each test case, output an integer denoting the maximum xyzxyz. If there no such integers, output −1−1 instead. 

Sample Input

3
1
2
3

Sample Output

-1
-1
1

x+y+z=n  若(x>=y>=z)

令a=1/x   b=1/y  c=1/z;

则1<=a<=3

a=1不可能的。

a=2 :b=4 c=4或 b=3  c=6;

a=3 :b=3 c=3;(包含了上面第二种)

所以只有这两种情况成立啦!

其他都是-1……

 

 


#include<cstdio>
#include<iostream>
using namespace std;

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int n;
        scanf("%d",&n);
        if(n%3==0)
        {

            printf("%I64d\n", 1ll *n*n*n/27);
        }
        else if(n%4==0)
            printf("%I64d\n", 1ll *n*n*n/32);
        else
            printf("-1\n");
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值