HDU 2141 Can you find it?(二分)

<strong>                                                 <span style="font-size:32px;">Can you find it?</span></strong>


<span style="font-size:24px;"><strong>Description</strong></span>
<span style="font-family:SimSun;font-size:18px;">Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if 
you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 
</span>
<span style="font-size:24px;"><strong>Input</strong></span>
<span style="font-family:SimSun;font-size:18px;">There are many cases. Every data case is described as followed: In the first line there are three 
integers L, N, M, in the second line there are L integers represent the sequence A, in the third line 
there are N integers represent the sequences B, in the forth line there are M integers represent the 
sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 
</span>
<strong><span style="font-size:24px;">Output</span></strong>
<span style="font-family:SimSun;font-size:18px;">For each case, firstly you have to print the case number as the form "Case d:", then for the S queries,
 you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print 
"NO".
 </span>

<span style="font-size:24px;"><strong>Sample Input</strong></span>

<span style="font-size:18px;">3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10 
</span>
 

<strong><span style="font-size:24px;">Sample Output</span></strong>

<span style="font-size:18px;">Case 1:
NO
YES
NO </span>

解决代码:
<span style="font-size:14px;">#include<stdio.h>
#include<algorithm>
using namespace std;
#define K 505
int LN[K*K];
int Find(int LN[],int h,int t)
{
    int left,right,mid;
    left=0;
    right=h-1;
    while(left<=right)
    {
        mid=(left+right)/2;
        if(LN[mid]==t)
          return 1;
        else if(LN[mid]>t)
          right=mid-1;
        else if(LN[mid]<t)
          left=mid+1;
    }
    return 0;
}
int main()
{
    int i,j,count=1,x;
    int L[K],N[K],M[K],S,n,m,l;
    while(scanf("%d%d%d",&l,&n,&m)!=EOF)
    {
        int h=0;
        for(i=0;i<l;i++)
         scanf("%d",&L[i]);
        for(i=0;i<n;i++)
          scanf("%d",&N[i]);
        for(i=0;i<m;i++)
          scanf("%d",&M[i]);
        for(i=0;i<l;i++)
          for(j=0;j<n;j++)
           LN[h++]=L[i]+N[j];
        sort(LN,LN+h);
        scanf("%d",&S);
        printf("Case %d:\n",count++);
        for(i=0;i<S;i++)
        {
            scanf("%d",&x);
            int p=0;
            for(j=0;j<m;j++)
            {
                int a=x-M[j]; 
                if(Find(LN,h,a))
                {
                    printf("YES\n");
                    p=1;
                    break;
                }
            }
            if(!p)
              printf("NO\n");
        }
    }
    return 0;
}</span>

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值