HDU1241 Oil Deposits

<span style="font-size:24px;">                          Oil Deposits</span>
<span style="font-size:14px;">Description
The GeoSurvComp geologic survey company is responsible for detecting
 underground oil deposits. GeoSurvComp works with one large rectangular
 region of land at a time, and creates a grid that divides the land into 
numerous square plots. It then analyzes each plot separately, using 
sensing equipment to determine whether or not the plot contains oil. 
A plot containing oil is called a pocket. If two pockets are adjacent, 
then they are part of the same oil deposit. Oil deposits can be quite 
large and may contain numerous pockets. Your job is to determine how 
many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line
 containing m and n, the number of rows and columns in the grid, separated 
by a single space. If m = 0 it signals the end of the input; otherwise 
1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n 
characters each (not counting the end-of-line characters). Each character 
corresponds to one plot, and is either `*', representing the absence of
 oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different 
pockets are part of the same oil deposit if they are adjacent horizontally,
 vertically, or diagonally. An oil deposit will not contain more than 
100 pockets.
 

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

 

Sample Output

0
1
2
2 </span>



<pre name="code" class="cpp"><span style="font-family:SimSun;font-size:14px;">#include<stdio.h>
#include<string.h>
using namespace std;
char map[105][105],s[105][105];
int vis[105][105];
void dfs(int i,int j)  
{  
    if(vis[i][j] || s[i][j] == '*')  
    return ;  
    vis[i][j] = 1;  
    dfs(i-1,j-1);  
    dfs(i-1,j);  
    dfs(i-1,j+1);  
    dfs(i,j-1);  
    dfs(i,j+1);  
    dfs(i+1,j-1);  
    dfs(i+1,j);  
    dfs(i+1,j+1);  
}
int main()
{
	int n,m;
	while(~scanf("%d%d\n",&n,&m)&&n!=0&&m!=0)
	{
		memset(map,0,sizeof(map));
		memset(vis,0,sizeof(vis));
		memset(s,'*',sizeof(s));
		int i,j,cnt=0;
		for(i=0;i<n;i++)
		{
			for(j=0;j<m;j++)
			{
				scanf("%c",&map[i][j]);
				s[i+1][j+1]=map[i][j];
			}
			getchar();
		}
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++)
			{
				if(!vis[i][j]&&s[i][j]=='@')
				{
					dfs(i,j);
					cnt++;
				}
			}
		}
		printf("%d\n",cnt);
	}
	return 0;
}</span>

 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值